[Pkg-xfce-devel] Bug#491480: further information

Daniel Gibson metalcaedes at gmail.com
Tue Aug 5 23:10:51 UTC 2008


I tried to find out more about the problem and collected some
information. I built the plugin "manually" and with --enable-debug
After adding it (followed by an immediate crash of the plugin) the
following was in .xsession-errors:
TRACE[sensors.c:2221] sensors_create_options(): enters sensors_create_options
TRACE[sensors.c:1571] init_widgets(): enters init_widgets
TRACE[sensors.c:1149] fill_gtkTreeStore(): enters fill_gtkTreeStore
TRACE[acpi.c:451] refresh_acpi(): enters refresh_acpi
TRACE[acpi.c:532] get_acpi_zone_value(): enters get_acpi_zone_value for thermal_
TRACE[acpi.c:553] get_acpi_value(): enters get_acpi_value for
TRACE[acpi.c:564] get_acpi_value(): leaves get_acpi_value with 44 C
TRACE[acpi.c:537] get_acpi_zone_value(): leaves get_acpi_zone_value
with correctly converted value
TRACE[acpi.c:487] refresh_acpi(): leaves refresh_acpi
TRACE[acpi.c:451] refresh_acpi(): enters refresh_acpi
TRACE[acpi.c:553] get_acpi_value(): enters get_acpi_value for fan/FAN1/state

** Message: Sensor-Plugin: screen changed: 0

** Message: No valid plug window.

(xfce4-panel:2893): Gtk-CRITICAL **: gtk_socket_get_id: assertion
`GTK_WIDGET_ANCHORED (socket)' failed

** (xfce4-panel:2893): CRITICAL **: Ein Element wurde unerwartet
entfernt: »Sensor-Plugin«.

Furthermore I googled for »"gtk_socket_get_id: assertion
`GTK_WIDGET_ANCHORED (socket)' failed" +sensors« and found a gentoo
bugreport[1] suggesting to deactivate acpi-support.
So I built the plugin with
./configure --enable-debug --disable-procacpi --prefix=/usr/
and it worked (at least the hddtemp-part, sensors don't work for me
anyway) - so most probably the acpi-support is broken.

I hope this can be fixed because the plugin is almost useless for me
without acpi-support.

- Daniel

[1] http://bugs.gentoo.org/224443

More information about the Pkg-xfce-devel mailing list