[Pkg-xfce-devel] Bug#481277: Bug#481277: exo-utils: exo-open doesn't like constant parameters for WebBrowser

Yves-Alexis Perez corsac at corsac.net
Fri May 16 12:45:23 UTC 2008

On Fri, May 16, 2008 at 03:45:02AM +0000, Daniel Dickinson wrote:
> On Thu, 15 May 2008 07:44:06 +0200
> Yves-Alexis Perez <corsac at corsac.net> wrote:
> > On mar, 2008-05-13 at 11:08 -0400, Daniel Dickinson wrote:
> > > Using a commandline like sudo -u iceweasel-user iceweasel "%s" as
> > > the preferred application for the the web browser confused exo-open.
> > > exo-open tried to execute just sudo (as detected by replacing sudo
> > > with echo and running from terminal), which doesn't work.  Other
> > > uses of preferred applications seem to be okay with this though
> > > (like the help browser).  It breaks the default web browser icon on
> > > the panel though.
> > 
> > I don't really get it (at least I don't get the subject at all).
> > 
> > Here if I try to use sudo, it “works”, but I don't have a chance to
> > enter my password. Using ktsuss, it works correctly.
> > 
> > What's the problem?
> If I use exo-preferred-applications and set the application for the web
> browser to Other...
> and specify
> sudo -u iceweasel-daniel iceweasel "%s"

> then exo-open --launch WebBrowser
> fails.  I get a dialog Input/Ouput error, and the following console
> message:


> When you used ktsuss did you get prompt and think it was working, or
> did the actual command run once you entered your password?

It worked, but I was testing with exo-open <url>. Seems that exo-open --launch
WebBrowser doesn't (confirmed with ktsuss).

Using exo-open <url> I guess it runs all the command (so command+args+url)
while running --launch WebBrowser it takes only the first word (or something
like that). I'll investigate on that. Stay tuned.


More information about the Pkg-xfce-devel mailing list