[Pkg-xfce-devel] Bug#522957: Still problems whit the shortcuts...

Luca Niccoli lultimouomo at gmail.com
Sun Apr 19 01:58:38 UTC 2009

reopen 522957

CC:ed Andrei in the hope he can help =)

Hi, I'm afraid I'm not through with this bug...
I upgraded to X 1.6 and now, even though shortcuts are shown right in
xfce4-keyboard-shortcuts, some of them don't work until I set them
The problematic ones are the ones with Super_L ad modifier, and the
XF86* keys, the rest works.
It doesn't happen with xfwm shortcuts (for instance I have set
Super_L+n for the virtual desktops, and it's got no problem).
I tried both keeping and commenting out these lines in xorg.conf:
	InputDevice	"Generic Keyboard"

(in ServerLayout) and

Section "InputDevice"
	Identifier  "Generic Keyboard"
	Driver      "kbd"
	Option	    "XkbRules" "xorg"
	Option	    "XkbModel" "pc105"
	Option	    "XkbLayout" "it"

Nothing changed.
I tried setting both "Evdev keyboard" and a specific keyboard model
that fits mine in xfce4-keybard-settings, but no luck...
I understand Andrei had the same problem, but I didn't really get how
he solved it...
The one thing I can't understand is that  xfce4-keyboard-shortcuts.xml
contain lines like:
<property name="XF86Display" type="string" value="xrandr --auto"/>
which don't change when I re-set the shortcut for the same action; so
it is not a problem with modfiers that change or so... it seems like
(wild guess) the shortcuts are read while the keyboard model is not
set yet, and these keys don't "exist".
$ xfconf-query -c xfce4-keyboard-shortcuts -p /commands/custom/XF86AudioMute
returns correctly
amixer -q sset 'Master' toggle
though it isn't working...
I must say I'm completely lost...


More information about the Pkg-xfce-devel mailing list