[Pkg-xfce-devel] Bug#525945: Bug#525945: Bug#525945: thunar fails to remount removable media when running as daemon

Yves-Alexis Perez corsac at debian.org
Tue Apr 28 11:48:11 UTC 2009

On mar, 2009-04-28 at 05:19 -0600, Scott Barker wrote:
> I did have thunar-volman installed, and the same thing was happening. I 
> removed it to verify it wasn't thunar-volman causing the issue.
> I have consolekit and policykit installed, and spent several hours 
> debugging that new level of complexity as well. I used to use 
> startxfce4, and had to switch to using startx with 'exec 
> ck-launch-session startxfce4' in $HOME/.xsession to make mounting (and 
> suspend/hibernate) work at all in the new model. I have verified that my 
> console session is correct (via ck-list-sessions) and that I have the 
> correct authorizations as well (via polkit-auth).

Hmhm ok. I guess we can eliminate a policy/auth stuff.
> The only way I have been able to reproduce the error consistently is by 
> running thunar as a daemon, mounting a USB device (by clicking on it in 
> thunar), unmounting it (by right-clicking on it in thunar), unplugging 
> it, plugging it back in, and trying to mount it again (by clicking on it 
> in thunar).

It happens with all the usb devices you tried?
Is there something in /var/log/syslog during the various mount/umounts?
Could you try lshal -m during those operations, too?

I tried to reproduce, but failed.


More information about the Pkg-xfce-devel mailing list