[Pkg-xfce-devel] Bug#528318: xfce4-terminal: terminal always segfaults when starting

Ian MacKinnell ianm at judcom.nsw.gov.au
Tue May 12 13:10:15 UTC 2009

Yves-Alexis Perez wrote:
> On mar, 2009-05-12 at 14:49 +1000, Ian MacKinnell wrote:
>> The XFCE4 terminal emulator suddenly ceased to work when I upgraded to 
>> the latest version (0.2.12.-1) and has not worked since. I have been 
>> using xterm as a workaround.
>> When I try to start xfce4-terminal from a command prompt, it segfaults 
>> instantly. No window appears. Example session:
>>     $xfce4-terminal
>>     Segmentation fault
>>     $
> Can you provide a backtrace, with debugging symbols?
Not without instructions. I can supply strace.
>> This problem occurs on my work desktop PC, where the details below come 
>> from. It also occurs on my home desktop PC (running Debian squeeze, all 
>> packages up-to-date) and on my laptop running Xubuntu (the problem 
>> occurred on that machine when I updated to Jaunty Jackelope).
>> All three machines happen to have Intel graphics chipsets of various 
>> kinds and all run X with xserver-xorg-video-intel.
> Do you have some weird config on all three? Do you use compositing?
> I definitely can't reproduce, neither on lenny or sid.
> You may want to try gnome-terminal too and see if it breaks too.
> Cheers,

No compositing. I even switched xserver to vesa and still got a segfault.

However, to test a fresh home directory with no legacy configuration, I 
created a new user account and logged in as this user. I then tried 
xfce4-terminal and it worked OK. So it looks like my existing user 
configuration either conflicts with the new version of the terminal, or 
else got fried somehow when I updated to xfce 4.6.

Gnome terminal works fine.

More information about the Pkg-xfce-devel mailing list