[Pkg-xfce-devel] Bug#623496: Bug#623496: Bug#623496: thunar-volman: Fails to recognize removable drives

Sebastian Dalfuß sd at sedf.de
Thu Apr 21 13:55:07 UTC 2011

On Thu, Apr 21, 2011 at 02:47:24PM +0200, Yves-Alexis Perez wrote:
> severity 623496 minor
> thanks
> On jeu., 2011-04-21 at 14:32 +0200, Sebastian Dalfuß wrote:
> > Hi,
> > I manually invoked startx with startxfce4 like you suggested, didn't make
> > any difference. To verify the wy og login isn't the problem, I then used
> > a default inittab and installed/used xdm to login. That didn't help either.
> No idea about xdm, I wouldn't advise it. My reference test environments
> are gdm (2.20) and pure console (with .xsessionrc and startx).

Pure console is what I prefer to use, xdm was just for testing purposes,
I've now tried gdm (see below).

> Here, your session is only a console session, not a graphical session,
> and is marked as inactive. I'm not too sure about the xdm setup but it
> might be worth installing the pam connector (libpam-ck-connector) and
> retrying.

libpam-ck-connector was already installed.

This is ck-list-sessions after booting with gdm:
	unix-user = '1000'
	realname = ''
	seat = 'Seat1'
	session-type = ''
	active = TRUE
	x11-display = ':0'
	x11-display-device = '/dev/tty7'
	display-device = ''
	remote-host-name = ''
	is-local = TRUE
	on-since = '2011-04-21T13:12:30.160505Z'
	login-session-id = ''

The ck-Session is now marked active and has x11-display properly set,
but behaviour/output from thunar/thunar-volman didn't change.

Out of desperation I also ran the X/Xfce session as root, still no difference.

Could it be that there's something else missing (e.g. thunar-volman dosn't
recommend or suggest udisks, should I file a seperate bug about that?)?


More information about the Pkg-xfce-devel mailing list