[Pkg-xfce-devel] Bug#612504: Bug#612504: xfce4-session: Attempted suspend causes logout and segfault

Brandon Simmons brandon.m.simmons at gmail.com
Wed Feb 9 18:05:13 UTC 2011

On Wed, Feb 9, 2011 at 11:19 AM, Yves-Alexis Perez <corsac at debian.org> wrote:
> On mer., 2011-02-09 at 10:54 -0500, Brandon Simmons wrote:
>> On Wed, Feb 9, 2011 at 1:11 AM, Yves-Alexis Perez <corsac at debian.org> wrote:
>> > On mar., 2011-02-08 at 18:56 -0500, Brandon Simmons wrote:
>> >> As for the backtrace, I'll need some hints on how to do that. I
>> >> re-built the 'xfce4-session' package with debugging symbols and
>> >> attempted to get a backtrace of "xfce4-session-logout --suspend" per
>> >> these instructions:
>> >>
>> >>     http://wiki.debian.org/HowToGetABacktrace
>> >>
>> >> but I was instantly logged out of my session. I also tried to dump a
>> >> backtrace to a file using this trick:
>> >
>> > xfce4-session-logout doesn't segfaults, it's xfce4-session. Try to
>> > attach it using gdb -p $(pid xfce4-session). You should do it from a
>> > console or from ssh since when it'll be killed the session might be
>> > frozen.
>> I had gdb running in a separate TTY with:
>>     $ gdb x-session-manager $(pidof x-session-manager)
>> And when I ran in TTY 7
>>     $ xfce4-session-logout --suspend
>> I got the message "Failed to receive a reply from the session
>> manager".
> I'd say this is because it was stuck in gdb on tty1.
>>  However, after quitting gdb the system immediately suspended
>> successfully (and when it came back up it went into suspend again,
>> presumably because I had tried the suspend command above twice).
> As xfce4-session had segfaulted but not yet quitted (stuck in gdb) its
> children weren't killed and in particular the suspend order was
> correctly processed. At least that's how I see it.
>> At this point suspend seems to be working normally for whatever
>> reason. I'm sure it is unrelated to the debugging I just did, but I
>> thought I would mention the process I went through, since I haven't
>> done anything else with it in the meantime.
> Do you mean that it now works even without any gdb debugging?

Yes. Sorry to be unclear.

>> One final thing to mention: when suspend stopped working, I was asked
>> for my password when I tried to suspend from the GUI logout screen;
>> this never happened before. After entering it I was logged out.
> That looks like a Consolekit/Policykit issue.
>> Anyway thanks for the help in trying to resolve this.
> So what's the status right now?

Seems to be working. I did a restart yesterday, and I assume it had
been working since then, but I hadn't tested it again until trying to
do the debugging today.


> Regards,
> --
> Yves-Alexis

More information about the Pkg-xfce-devel mailing list