[Pkg-xfce-devel] Kudos for Xfce 4.8 in experimental

Dave Witbrodt dawitbro at sbcglobal.net
Wed Mar 9 03:57:01 UTC 2011

Thanks to the Debian Xfce Maintainers for the Xfce 4.8 packages in 
experimental.  It seems like I waited for libgarcon (and the other 
couple of packages) for 2 months!

Of course, many of the plugins aren't ready... but I got tired of 
waiting and decided to fight with them to see if I could get them to 
build locally.  The results were mixed.

I was only using 7 plugins (plus xfprint4) that were not ready for v4.8 
when I made the upgrade.  Here are some notes I took during the builds.

1.  xfce4-clipman-plugin:  the autobuild system actually requires 
libexo-0.3, even if you modify debian/control to depend on
'libexo-1-dev'.  Bummer.

2.  xfce4-datetime-plugin:  builds OK.  (Thought I had this on one of my 
panels, but I was wrong... so I haven't tried it yet to see if it works.)

3.  xfce4-screenshooter:  had to finesse the build with

     LIBS='-lX11 -lXext' dpkg-buildpackage -r -D -b -us -uc

Recent changes to gcc prevent some of the automatic linker resolutions 
which used to work from working now; lots of packages are FTBFS'ing now, 
so I was expecting this sort of thing.  Program showed up in its
previous position on the bottom panel and works fine!

4.  xfce4-sensors-plugin: what a nightmare.  This was the most important 
plugin for me to get working, so that I can monitor my CPU,  GPU, and 
hard disk temps.  When I started having lots of trouble getting it to 
build, I thought, "Just my luck, the one I really need isn't going to 

I eventually got it to work, but purely in a workaround fashion.  I had 
to use an astronomically-long LIBS variable,

     LIBS='-lm -lxfcegui4 -lxfce4panel-1.0 -lxfce4util -lgtk-x11-2.0
           -lgdk-x11-2.0 -lgdk_pixbuf-2.0 -lcairo -lpango-1.0
           -lgobject-2.0 -lglib-2.0'  dpkg-buildpackage  ...

I also had to tweak the Makefile in ./src to add


in several places, and then build with the "-nc" to prevent the clean 
target from running before the next build attempt.  I feel that it was 
pure luck that I actually got it to build.  The funnist part is that it 
works just fine!

5.  xfce4-taskmanager:  builds OK, runs fine.  (Is this a plugin?  I 
seem to recall having it on my panel, but it wasn't there after the 
upgrade, and I cannot seem to add it to the panel....)

6.  xfce4-timer-plugin:  builds OK, but won't run.

7.  xfprint4:  builds OK, if I help the build system find libX11 ...

     LIBS='-lX11' dpkg-buildpackage -r -D -b -us -uc

Seems to run OK, though I do get a warning

     ** (xfprint4:14129): WARNING **: Unable to load printing system
     module cups_plugin.so

But the file I asked it to print was sent to CUPS and printed just fine.

So I've had a busy day -- local builds of kernel 2.6.38-rc8, 
libdrm-2.4.24, mesa-7.11.0-devel -- in addition to upgrading Xfce.  I 
have not been able to test Xfce very much yet, but I can make a few 
early observations:

A.  Menus are not working -- .xsession-errors gets this:

     ** (xfdesktop:7722): WARNING **: Unable to load menu:
     File "menus/applications.menu" not found

Adding the Applications Menu launcher on a panel gives an error dialog 
box with the same message about not finding 'menus/applications.menu'. 
This is a serious setback:  I have to run all programs from the 
terminal.  (Yes, xfce4-terminal is working great!)

B.  My second favorite Xfce plugin, xfce4-notes-plugin, was not present 
on the panel when I upgraded.  This is not something that I build 
locally, but a new one from experimental which should work with 4.8.  It 
may actually work OK, but I need to find my old notes data and save them 
before trying to run the new version of xfce4-notes-plugin; I actually 
had some important material saved there, and now that the plugin 
disappeared from the panel I'm paranoid about running the new one until 
I find out whether I can salvage my old notes first!

C.  The xfce4-cpugraph-plugin (from experimental) runs, but will not 
allow me to right-click on it and adjust its properties.

D.  mousepad, which is still the same version I had installed with Xfce 
4.6, still runs fine.

E.  The upgraded Workspace Switcher and Mixer apps seem to work good, too.

For now, I'll refrain from filing bug reports until updated plugin 
packages appear in the Debian repositories.  This will give me some time 
to try to find out what is going wrong with the menus, and what else is 
going right or wrong with the rest of Xfce 4.8.

Thanks again,
Dave W.

More information about the Pkg-xfce-devel mailing list