[Pkg-xfce-devel] Bug#755234: Bug#755234: Fix only 1/2 works... :-(

Martin Schwenke martin at meltin.net
Mon Aug 4 10:56:49 UTC 2014

On Mon, 04 Aug 2014 08:03:26 +0200, Yves-Alexis Perez
<corsac at debian.org> wrote:

> I guess you're using systemd as init system? Then it's logind handling
> the suspend part. Try to configure /etc/systemd/logind.conf to hands off
> suspend.

Thanks, I've now tried that.

Now for the rant that's not aimed at you.  I'll keep it to a
minimum  :-)

I've tried everything I can think of, including "systemctl
daemon-reload" but nothing seems to reload the settings.  I would have
thought that logind.conf(5) would tell me how to reload the file after
it is modified.  I can't believe that in 2014 I would have to logout
and/or reboot to reload the configuration for a modern piece of
software.  Stunning...

Beyond that, I'm speechless at the way systemd is taking over
functionality that doesn't belong in an init system.

Anyway, that's enough... sorry...

There's a patch here:


so that xfce4-power-manager can inhibit systemd from handling suspend
and related events.  However, I can't get it to build.  :-(  

peace & happiness,
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 173 bytes
Desc: not available
URL: <http://lists.alioth.debian.org/pipermail/pkg-xfce-devel/attachments/20140804/74850e04/attachment.sig>

More information about the Pkg-xfce-devel mailing list