[Pkg-xfce-devel] Bug#755234: Bug#755234: Fix only 1/2 works... :-(

Martin Schwenke martin at meltin.net
Mon Aug 4 11:45:32 UTC 2014

On Mon, 04 Aug 2014 13:04:00 +0200, Yves-Alexis Perez
<corsac at debian.org> wrote:

> On lun., 2014-08-04 at 20:56 +1000, Martin Schwenke wrote:
> > On Mon, 04 Aug 2014 08:03:26 +0200, Yves-Alexis Perez
> > <corsac at debian.org> wrote:
> > 
> > > I guess you're using systemd as init system? Then it's logind handling
> > > the suspend part. Try to configure /etc/systemd/logind.conf to hands off
> > > suspend.
> > 
> > Thanks, I've now tried that.
> And does it work?

I'm not sure.  As I mentioned in my rant, it doesn't seem possible to
reload logind.conf without some sort of restart.  I can't logout at the
moment because I have a lot of context (i.e. state of unfinished work)
in my current session.

So, either:

* no - my attempts to reload logind.conf worked but for another reason
  my laptop still suspends when I close the lid; or

* yes - but I'll only confirm that when I get a chance to

The following seems to suggest that logind.conf hasn't been reloaded:

  # loginctl show-user | grep HandleLidSwitch

[Why is "show-user" overloaded to show the daemon configuration?  That
 was stupidly hard to find...]

so it looks like the 2nd possibility.  I might get a chance to
logout/restart some time in the next week - I usually only do so about
once a month - when I do then I'll update this bug...

Thanks again...

peace & happiness,
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 173 bytes
Desc: not available
URL: <http://lists.alioth.debian.org/pipermail/pkg-xfce-devel/attachments/20140804/bea61c83/attachment.sig>

More information about the Pkg-xfce-devel mailing list