[Pkg-xfce-devel] Bug#756770: Bug#756770: xfce4-whiskermenu-plugin: it segfaults

Moritz Molle mmolle at gmx.net
Mon Aug 4 14:44:22 UTC 2014

It gets even more fascinating :)
To get debug information, i tried to compile it myself. To get the right 
version (the one in jessie) i got the source by
apt-get source xfce4-whiskermenu-plugin
apt-get build-dep xfce4-whiskermenu-plugin

I amended the WHISKERMENU_FLAGS in CMakeList.txt by -g

then I tried

debian/rules binary

yadda yadda. compile. scroll...

&& ./libwhiskermenu.so
/bin/sh: Zeile 1: 31230 Speicherzugriffsfehler  ./libwhiskermenu.so
panel-plugin/CMakeFiles/whiskermenu.dir/build.make:643: recipe for 
target 'panel-plugin/libwhiskermenu.so' failed

('Speicherzugriffsfehler' is segfault)

I then tried to do this by hand in gdb (I really don't quite get why you 
would run a .so?!)

mmolle at mokbox:~/xfce4-whiskermenu-plugin-1.3.2/obj-i486-linux-gnu/panel-plugin$ 
gdb ./libwhiskermenu.so
GNU gdb (GDB) 7.6.2 (Debian 7.6.2-1.1+b1)
Copyright (C) 2013 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later 
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "i486-linux-gnu".
For bug reporting instructions, please see:
Reading symbols from 
(gdb) run
Starting program: 

Program received signal SIGSEGV, Segmentation fault.
__exchange_and_add_dispatch (__val=-1, __mem=0x8)
     at /usr/include/c++/4.9/ext/atomicity.h:84
84	      return __exchange_and_add_single(__mem, __val);



Yves-Alexis Perez wrote, On 01.08.2014 17:50:
> On ven., 2014-08-01 at 16:42 +0200, Moritz Molle wrote:
>>     * What led up to the situation?
>> I inserted the Whiskermenu into my xfce-panel. The icon appeared and i
>> clicked it. Xfce informed me, the plugin had crashed.
>> Also dmesg said this:
>> [93815.848872] panel-25-whiske[23910]: segfault at 8 ip b6ca3d26 sp
>> bf9be3a4 error 4 in libc-2.19.so[b6c21000+1a5000]
> It seems to work just fine for me. Can you provide a backtrace? See
> http://docs.xfce.org/xfce/xfce4-panel/debugging for some help.
> Regards,

More information about the Pkg-xfce-devel mailing list