[Pkg-xfce-devel] Bug#754928: xfsettings doesn't actually talk to xinput as documented

Antoine Beaupré anarcat at debian.org
Wed Jul 16 04:14:47 UTC 2014

Package: xfce4-settings
Version: 4.10.1-2
Severity: normal

In this documentation:


it is said that "Xfsettingsd is capable of setting all sorts of device
properties", and goes about showing an example on how to set arbitrary
xinput settings with xfconf.

I happen to want to set the "Evdev Middle Button Emulation" setting,
having only a crippled, two button mouse.

The following works:

    xinput --set-prop 9 'Evdev Middle Button Emulation' 1

Note that I have the following input device defined:

anarcat at marcos:~$ xinput --list
⎡ Virtual core pointer                          id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
⎜   ↳ Logitech USB-PS/2 Optical Mouse           id=8    [slave  pointer  (2)]
⎜   ↳ Primax Kensington Eagle Trackball         id=9    [slave  pointer  (2)]
⎣ Virtual core keyboard                         id=3    [master keyboard (2)]
    ↳ Virtual core XTEST keyboard               id=5    [slave  keyboard (3)]
    ↳ Power Button                              id=6    [slave  keyboard (3)]
    ↳ Power Button                              id=7    [slave  keyboard (3)]
    ↳ LITEON Technology USB Multimedia Keyboard id=10   [slave  keyboard (3)]
    ↳ LITEON Technology USB Multimedia Keyboard id=11   [slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard              id=12   [slave  keyboard (3)]

According to the above documentation, I would have expected the
following to work as well:

xfconf-query -c pointers -p /Primax_Kensington_Eagle_Trackball/Evdev_Middle_Button_Emulation -n -t bool -s true

This does set the parameter in the xfconf registry, but doesn't
propagate it to the xinput listing:

anarcat at marcos:~$ xinput list-props 9 | grep 262
        Evdev Middle Button Emulation (262):    0

I have also tried the following settings:

xfconf-query -c pointers -p /Primax_Kensington_Eagle_Trackball/Evdev_Middle_Button_Emulation -n -t bool -s 1
xfconf-query -c pointers -p /Primax_Kensington_Eagle_Trackball/Evdev_Middle_Button_Emulation -n -t bool -s true
xfconf-query -c pointers -p /Primax_Kensington_Eagle_Trackball/Evdev_Middle_Button_Emulation -n -t int -s 1
xfconf-query -c pointers -p /Primax_Kensington_Eagle_Trackball/Middle_Button_Emulation -n -t bool -s true
xfconf-query -c pointers -p /Primax_Kensington_Eagle_Trackball/Properties/Evdev_Middle_Button_Emulation -n -t bool -s true
xfconf-query -c pointers -p /Primax_Kensington_Eagle_Trackball/Properties/Middle_Button_Emulation -n -t bool -s true
xfconf-query -c pointers -p /Primax_Kensington_Eagle_Trackball/Properties/Middle_Button_Emulation -n -t int -s 1

none would actually affect xinput.

In fact, I have also tried the seemingly magic:

    xinput --watch-props 9

for changes, but even when i would change working settings in the
mouse settings dialog (like acceleration or right/lefthandedness), no
change would occur there.

Therefore, there must be a problem with the documentation, or between
this keyboard and chair.

Please enlighten.



-- System Information:
Debian Release: jessie/sid
  APT prefers testing
  APT policy: (500, 'testing'), (1, 'unstable')
Architecture: amd64 (x86_64)
Foreign Architectures: i386

Kernel: Linux 3.14-1-amd64 (SMP w/2 CPU cores)
Locale: LANG=fr_FR.utf8, LC_CTYPE=fr_FR.utf8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages xfce4-settings depends on:
ii  libc6               2.19-5
ii  libcairo2           1.12.16-2
ii  libdbus-1-3         1.8.6-1
ii  libdbus-glib-1-2    0.102-1
ii  libexo-1-0          0.10.2-3
ii  libfontconfig1      2.11.0-5
ii  libgarcon-1-0       0.2.1-1
ii  libgarcon-common    0.2.1-1
ii  libgdk-pixbuf2.0-0  2.30.7-1
ii  libglib2.0-0        2.40.0-3
ii  libgtk2.0-0         2.24.24-1
ii  libnotify4          0.7.6-2
ii  libpango-1.0-0      1.36.3-1
ii  libx11-6            2:1.6.2-2
ii  libxcursor1         1:1.1.14-1
ii  libxfce4ui-1-0      4.10.0-5
ii  libxfce4util6       4.10.1-1
ii  libxfconf-0-2       4.10.0-2
ii  libxi6              2:1.7.2-1
ii  libxklavier16       5.2.1-1
ii  libxrandr2          2:1.4.2-1
ii  xfconf              4.10.0-2

Versions of packages xfce4-settings recommends:
ii  x11-utils      7.7+1
ii  xfce4-volumed  0.1.13-5

xfce4-settings suggests no packages.

-- no debconf information

More information about the Pkg-xfce-devel mailing list