[Pkg-xfce-devel] Bug#751663: Bug#751663: ristretto: I can't run ristretto. it gives "segmentation fault"

Kaze Shirotsuki kaze.tsuki17 at gmail.com
Tue Jun 17 14:01:31 UTC 2014

dmesg said:
[13524.326589] ristretto[13340]: segfault at 7fa308b86140 ip
00007fa329067db0 sp 00007fff39d4f450 error 7 in

while gdb said:
Reading symbols from /usr/bin/ristretto...done.
(gdb) run --sync
Starting program: /usr/bin/ristretto --sync
warning: Could not load shared library symbols for linux-vdso.so.1.
Do you need "set solib-search-path" or "set sysroot"?
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[New Thread 0x7fffec1e9700 (LWP 13429)]
[New Thread 0x7fffeb9e8700 (LWP 13430)]

Program received signal SIGSEGV, Segmentation fault.
0x00007ffff6db2db0 in gdk_pixbuf_saturate_and_pixelate (src=<optimized out>,
    dest=<optimized out>, saturation=<optimized out>, pixelate=0)
    at gdk-pixbuf-util.c:249
249	gdk-pixbuf-util.c: No such file or directory.

On 17/06/2014, Yves-Alexis Perez <corsac at debian.org> wrote:
> Control: tag -1 moreinfo unreproducible
> On mar., 2014-06-17 at 05:38 +0700, Kaze Shirotsuki wrote:
>> can you specify what should I do? I tried to follow the instruction on
>> that page but ristretto doesn't have dbg package thus it gives no
>> "debugging symbols found" message. I tried to run bt as well but it
>> only gives me "no stack" message
> Try to rebuild from source using debugging symbols?
> Also please keep the bug on CC:, I'm not a private support channel.
> Regards,
> --
> Yves-Alexis

More information about the Pkg-xfce-devel mailing list