[Pkg-xfce-devel] Bug#754850: upower 0.99 drops support for non-systemd

Adam Borowski kilobyte at angband.pl
Fri Sep 5 04:50:38 UTC 2014

A new version of upower packages came up -- so I just retested.

On Fri, Aug 15, 2014 at 10:30:28PM +0200, Andreas Henriksson wrote:
> On Fri, Aug 15, 2014 at 02:22:38AM +0200, Adam Borowski wrote:
> > On Fri, Aug 15, 2014 at 12:33:35AM +0200, Andreas Henriksson wrote:
> > > I fail to see any argument on why this is not already resolved.
> > 
> > Suspend and hibernate don't work if upower is upgraded, duh.
> [...]
> Could you please give a bit more details? "doesn't work" isn't very
> useful.

As of mid-August, both "suspend" and "hibernate" buttons were grayed out.
With current (Sep 04) versions from unstable, they are shown but show a
dialog box:
.--==[ Failed to suspend session ]
Operation not permitted

Probably related: I can't reboot or shutdown from the GUI as well, both
while logged on and from lightdm login screen.

> Also since this is a problem only affecting you:
> What did you do to your system to trigger the problem? How can
> it be reproduced?

On my real box:
* purged systemd-must-die
* unheld all utopia packages
* installed systemd-shim with dependencies
* dist-upgraded, bringing utopia up to date
* rebooted
* tried to suspend/hibernate
* tested that pm-utils do work -- all ok
* tried to reboot
* restored the system to the old state (thank gods and Chris Mason for btrfs!)

On virtualbox VM:
* installed from the jessie d-i Beta 1 image
* upgraded to unstable
* upgraded to sysvinit-core, installed systemd-shim
* rebooted
* messed with virtualbox-guest-{dkms,x11} to get proper X drivers
* rebooted
* tried suspending, hibernating, rebooting, etc.

On virtualbox VM:
* dist-upgraded the VM
* rebooted
* tried the stuff again
* installed your /etc/polkit-1/localauthority/50-local.d/suspend-hibernate.pkla
* rebooted
* tried the stuff yet again

> Fwiw, for your pleasure I just reverified this with a fresh install.
> Here are instructions on how to create a system with working suspend
> with xfce and sysvinit-core:
> Download http://cdimage.debian.org/cdimage/weekly-builds/amd64/iso-cd/debian-testing-amd64-xfce-CD-1.iso
> Install using the downloaded image (Select "Debian desktop environment")
> Install systemd-shim and related packages (libsystemd-login0,
> libsystemd-journal0, libsystemd-daemon0, libpam-systemd, systemd, systemd-sysv)
> from Unstable -- as systemd-shim in testing is not in a good shape.
> Run "apt-get install -f" to pull in cgmanager, etc.
> Install sysvinit-core (and let it replace systemd-sysv).
> Reboot.

Ie, basically what I did (except for dist-upgrading everything to unstable).

> Notice you have lost access to trigger suspend.
> Work around your lack of a proper system configuration by manually
> configuring policykit. eg. allow users in sudo group to trigger suspend:
> sudo cat <<EOF>/etc/polkit-1/localauthority/50-local.d/suspend-hibernate.pkla
> /etc/polkit-1> cat ./localauthority/50-local.d/org.freedesktop.upower.pkla
> [Suspend/hibernate permissions]
> Identity=unix-group:sudo
> Action=org.freedesktop.login1.hibernate;org.freedesktop.login1.suspend
> ResultAny=yes
> ResultInactive=yes
> ResultActive=yes

That's not something an user should need to do.  And even if you added this
configuration by default, only people in the sudo group would be able to
suspend -- rather than whoever is logged on.

> Ofcourse, if you want to avoid fiddling around with undermaintained software
> you could always install/keep systemd-sysv instead. ;)

I did not break this, the utopia team did.  Just keeping the packages at
their working version would work -- so it's not a matter of
"undermaintained", it's "maintained in a bad way".  Inaction would be enough
(or at the moment, reverting to wheezy's or mid-jessie-cycle state).

And on 3 out of 5 machines in the room I'm currently I can't even install
systemd-sysv even if I somehow wanted to.

But back to the problem at hand:
could you list your test environment, so I could see any setup where upower
_does_ work?

// If you believe in so-called "intellectual property", please immediately
// cease using counterfeit alphabets.  Instead, contact the nearest temple
// of Amon, whose priests will provide you with scribal services for all
// your writing needs, for Reasonable and Non-Discriminatory prices.

More information about the Pkg-xfce-devel mailing list