Bug#584313: Vorbis libraries (libvorbis, libvorbisenc, libvorbisfile) _must_ be updated as a set; not always happening

John Ferlito johnf at inodes.org
Tue Feb 15 13:07:31 UTC 2011

Hi Monty,

On Thu, Jun 03, 2010 at 02:09:40AM -0400, Monty Montgomery wrote:
> We had a user stumble into #vorbis with Debian Unstable oggenc that
> produced corrupt Vorbis files.  Investigation revealed that he still
> had an ancient libvorbisenc (.so.2.0.3) installed along with a fully
> up-to-date libvorbis0a-1.3.1-1 and vorbis-tools 1.4.0.  The package
> system was aware of the old install, but the package depends were
> satisfied (incorrectly), so nothing triggered pulling in a required
> matching libvorbisenc2. This is possibly because his libvorbisenc
> likely predated the libs being split into seperate packages.
> Libvorbis0a does not force an update of the other libs/packages, and
> the older libs were still satisfying the >= depends of the tools
> packages.

Without access to the users system in the broken state this was is
going to be hard to debug. You mentioned that the user had
vorbis-tools 1.4.0 installed. This should make the situation you
describe impossible since

  Package: vorbis-tools
  Depends: <SNIP>, libvorbis0a (>= 1.1.2), libvorbisenc2 (>= 1.1.2), libvorbisfile3 (>= 1.1.2)

So installing vorbis-tools 1.4.0 should have pulled in libvorbisenc2.

The old package used to be called libvorbis0 and contained all three
libraries and there is an explicit conflicts against that.

So I can only assume that the user installed something manually or has
had something strange happen with packaging in the past.

Going to close this until we have a system where we can investigate
this further.


Blog                             http://www.inodes.org
LCA2011                          http://www.lca2011.org.au

More information about the pkg-xiph-maint mailing list