Bug#606224: oggvideotools: oggJoin fails on powerpc

Martin Steghöfer martin at steghoefer.eu
Mon Sep 21 18:07:04 UTC 2015

found 606224 0.8a-1

Since there was no more feedback from the bug reporter, I tried to 
reproduce this on my own. I don't have access to a ppc machine, but 
managed to get a Debian Wheezy running in a QEMU-emulated big-endian 
MIPS machine, on which I could reproduce the problem with oggvideotools 
0.8a-1. So far I haven't tried any other versions because I'd have to 
compile them from source, which can be a pain in the emulator. But 
judging from the diff between 0.8a-1 and the current version 0.8a-3, the 
problem is probably still present (if oggvideotools is the actual 
culprit, and not some underlying library).


Petter Reinholdtsen wrote:
> [Daniel Kahn Gillmor]
>> I haven't tested recently, and won't have access to a ppc machine for a
>> few days.  feel free to ping me later if i haven't made it back to test
>> this, though.
>> thanks for picking up this package!
> Did you manage to test if oggJoin still fail on powerpc?  Perhaps you
> can send us a test script to run during build to discover the problem?

More information about the pkg-xiph-maint mailing list