[Reportbug-maint] Bug#552364: reportbug: doesn't properly depend on a recent debsums

Flavio Stanchina flavio at stanchina.net
Sun Oct 25 18:30:24 UTC 2009

Package: reportbug
Version: 4.8
Severity: normal

I upgraded reportbug to the version in testing but I still have debsums
from lenny. Now I get this message when I run reportbug:

  There may be a problem with your installation of reportbug;
  the following problems were detected by debsums:
  Unknown option: ignore-permissions
  Try 'debsums --help' for more information.
  Do you still want to file a report [y|N|q|?]? 

This is caused by the fix to bugs #536576 and #539695: reportbug now
needs at least version 2.0.47 of debsums. The version was added to the
Suggests line, as reportbug doesn't depend on debsums but only suggests
it, but unfortunately versioning doesn't work in the Suggests line.

IIRC, the proper solution is to leave an unversioned Suggests and add a
versioned Conflicts: debsums (<< 2.0.47)

-- Package-specific info:
[removed as it is not relevant]

-- System Information:
Debian Release: squeeze/sid
  APT prefers stable
  APT policy: (500, 'stable'), (400, 'testing'), (300, 'unstable')
Architecture: i386 (i686)

Kernel: Linux (SMP w/2 CPU cores)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages reportbug depends on:
ii  apt             Advanced front-end for dpkg
ii  python                   2.5.2-3         An interactive high-level object-o
ii  python-reportbug         4.8             Python modules for interacting wit

reportbug recommends no packages.

Versions of packages reportbug suggests:
ii  courier-mta [mail-transpo 0.60.0-2       Courier mail server - ESMTP daemon
ii  debconf-utils             1.5.24         debconf utilities
ii  debsums                   2.0.36         verification of installed package 
pn  dlocate                   <none>         (no description available)
ii  file                      4.26-1         Determines file type using "magic"
ii  gnupg                     1.4.9-3+lenny1 GNU privacy guard - a free PGP rep
ii  python-gtk2               2.12.1-6       Python bindings for the GTK+ widge
pn  python-gtkspell           <none>         (no description available)
ii  python-urwid          curses-based UI/widget library for
pn  python-vte                <none>         (no description available)
ii  xdg-utils                 1.0.2-6.1      desktop integration utilities from

-- no debconf information

-- debsums errors found:
Unknown option: ignore-permissions
Try 'debsums --help' for more information.

More information about the Reportbug-maint mailing list