[Reportbug-maint] Bug#640552: reportbug: Forces me to reset my terminal

Sandro Tosi morph at debian.org
Sat Sep 10 21:34:22 UTC 2011

tags 640552 unreproducible


On Mon, Sep 5, 2011 at 20:21, Torquil Macdonald Sørensen
<torquil at gmail.com> wrote:
> Package: reportbug
> Version: 6.2
> Severity: important
> Hi!
> I'm having some serious problems with reportbug (text ui). However, these
> problems won't show in a transcript...
> Most of the times that I try to view a follow-up for a bug, my terminal
> just goes completely blank and it forces me to reset my terminal after
> I manage to quit reportbug.

what terminal emulator are you using? have you tried on another one
(f.e. xterm)? have you tried on a real one (tty1 f.e.)?

> E.g., the following happens when I run 'reportbug reportbug', and view the first
> report on the list. The following illustrates the problem(s):
> $ reportbug reportbug
> I wait for output. Output is displayed after a short while.
> Type 1 and Enter to select the first report.
> I'm now inside a 'pager'. I can now see 'sensible-pager' and 'pager'
> when I run 'ps -u tmac' in another terminal.
> I type q to exit from the report.
> I am no longer in a pager. My goal is now to see the first follow-up
> report.
> I type ? and Enter. I see that the choice N means to view the follow-up,
> and it is pre-selected (capitalized).
> So I hit Enter

I replicated up till here without problem.

> Terminal just goes blank...

what do you mean?

> And I am again inside a pager. Being in a pager now is expected.

more over, how this fits with the line above? do you use a graphical
pager, so that the terminal is "detached"?

> I type q, but the letter q appears in the terminal instead of quitting
> the pager. I hit Enter. Now it says "(END)" on the line after the letter q.
> I hit q and Enter again. Reportbug exits and I am at the command prompt.
> But my keystrokes do not cause any letters to appear in the terminal.

I can't replicate this behavior; what pager do you use? I use less,
and I can't see these problems.

> I have to reset the terminal either by running the command 'reset' or
> or selecting 'reset terminal' from the menu to fix it.
> It has been like this for some time, perhaps a few weeks or up to a
> month or two (I think).

It would probably be helpful to precisely pinpoint the moment when it
happened, in particular in regards to reportbug installations and/or
other programs affecting this behavior.

I suspect is something other than reportbug generating this: there's a
lot of people using your workflow, and being only you to report this
problem makes me thing it's your setup that's non-functional.

Sandro Tosi (aka morph, morpheus, matrixhasu)
My website: http://matrixhasu.altervista.org/
Me at Debian: http://wiki.debian.org/SandroTosi

More information about the Reportbug-maint mailing list