[Reportbug-maint] Bug#640552: reportbug: Forces me to reset my terminal

Torquil Macdonald Sørensen torquil at gmail.com
Tue Sep 20 15:41:38 UTC 2011

> what terminal emulator are you using? have you tried on another one
> (f.e. xterm)? have you tried on a real one (tty1 f.e.)?

I use xfce4-terminal, but the problem persists while using xterm. Using tty1 I 
get another weird problem: When I try to open this very report (by selecting 22 
after bringing forth the bug list for reportbug, I get the message

Invalid reportbug number: #640552

which is strange since that is the correct number for this report... After that 
it prints again the list of reportbug reports, numbered from 1, instead of 
showing me bug #640552.

>> Terminal just goes blank...
> what do you mean?

I mean that my xfce4-terminal then contains no characters whatsoever. I could 
also say "black", since my terminal is configured to use white letters on a 
black background.

>> And I am again inside a pager. Being in a pager now is expected.
> more over, how this fits with the line above? do you use a graphical
> pager, so that the terminal is "detached"?

I am inside a pager which shows nothing on the screen. I.e. the same as if you
just run "less" from the command line. Something like running the command "echo 
| less", or "less -f /dev/null", or something.

>> I type q, but the letter q appears in the terminal instead of quitting
>> the pager. I hit Enter. Now it says "(END)" on the line after the letter q.
>> I hit q and Enter again. Reportbug exits and I am at the command prompt.
>> But my keystrokes do not cause any letters to appear in the terminal.
> I can't replicate this behavior; what pager do you use? I use less,
> and I can't see these problems.

I use /bin/less.

>> I have to reset the terminal either by running the command 'reset' or
>> or selecting 'reset terminal' from the menu to fix it.
>> It has been like this for some time, perhaps a few weeks or up to a
>> month or two (I think).
> It would probably be helpful to precisely pinpoint the moment when it
> happened, in particular in regards to reportbug installations and/or
> other programs affecting this behavior.
> I suspect is something other than reportbug generating this: there's a
> lot of people using your workflow, and being only you to report this
> problem makes me thing it's your setup that's non-functional.

I'll try some older reportbug version to see of this will fix the issue, and if 
so, try to pinpoint exactly when the problem was introduced. I did try to unset 
the variables LESS, LESSOPEN and LESSCLOSE, but it had no influence. I have also
regenerated the configuration file (although I had to edit manually due to a 
unicode problem, reported independently)

I'll get back here with more information.

Best regards
Torquil Sørensen

More information about the Reportbug-maint mailing list