[Reproducible-commits] [dpkg] 10/61: u-a: Rename alternative_remove to alternative_remove_files

Jérémy Bobbio lunar at moszumanska.debian.org
Mon Sep 21 09:56:03 UTC 2015


This is an automated email from the git hooks/post-receive script.

lunar pushed a commit to branch pu/reproducible_builds
in repository dpkg.

commit 73b937b90836e15a56e75bd86814e32b825ef9eb
Author: Guillem Jover <guillem at debian.org>
Date:   Fri Aug 7 19:11:23 2015 +0200

    u-a: Rename alternative_remove to alternative_remove_files
    
    We will use this name for the actual alternative remove action.
---
 utils/update-alternatives.c | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/utils/update-alternatives.c b/utils/update-alternatives.c
index f598659..0af4b97 100644
--- a/utils/update-alternatives.c
+++ b/utils/update-alternatives.c
@@ -1842,7 +1842,7 @@ alternative_prepare_install(struct alternative *a, const char *choice)
 }
 
 static void
-alternative_remove(struct alternative *a)
+alternative_remove_files(struct alternative *a)
 {
 	struct slave_link *sl;
 
@@ -2324,7 +2324,7 @@ alternative_update(struct alternative *a,
 	/* No choice left, remove everything. */
 	if (!alternative_choices_count(a)) {
 		log_msg("link group %s fully removed", a->master_name);
-		alternative_remove(a);
+		alternative_remove_files(a);
 		return;
 	}
 

-- 
Alioth's /usr/local/bin/git-commit-notice on /srv/git.debian.org/git/reproducible/dpkg.git



More information about the Reproducible-commits mailing list