[Reproducible-commits] [dpkg] annotated tag 1.15.5 created (now 59d8530)

Holger Levsen holger at layer-acht.org
Tue May 3 08:43:23 UTC 2016


This is an automated email from the git hooks/post-receive script.

holger pushed a change to annotated tag 1.15.5
in repository dpkg.

        at  59d8530   (tag)
   tagging  a0e6a6d395b0e152c28a11407ed0f24991cbe5f2 (commit)
  replaces  1.15.4.1
 tagged by  Guillem Jover
        on  Tue Nov 17 10:18:28 2009 +0100

- Log -----------------------------------------------------------------
Release 1.15.5
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.10 (GNU/Linux)

iEYEABECAAYFAksCamYACgkQuW9ciZ2SjJu+XACfeckMrcAXFtBUZFQ7zNGovAgN
inQAnRvVeh9sd6ES58XKcml9AU17oUnS
=j1iR
-----END PGP SIGNATURE-----

Christian Perrier (11):
      Fix error in French manpages translation
      Merge conflicts
      Updated French translation
      Updated French translation of dselect
      French manpages translations
      Fix grammatical error
      French translation update
      French manpages translation update and typographical fixes (non-breakable spaces)
      fix errors spotted by Raphaël
      Remerge with HEAD
      Merge changelog entries

David Benjamin (2):
      dpkg: Split off emptying a package's file info
      dpkg: Refactor file addition into package files to a new function

Felipe Contreras (1):
      build: If there's no libselinux.pc file fallback to hardcoded list

Frank Lichtenheld (1):
      Remove myself from Uploaders

Guillem Jover (150):
      Bump version to 1.15.5
      dpkg: Remove obsolete conffiles on purge
      Add additional bug closures
      Use character arrays instead of pointers for constant strings
      Only use errno for error reason when securely removing a file
      Rename chmodsafe_unlink functions to secure_unlink
      Improve secure_unlink comment and move it outside the function
      dpkg: Use secure_unlink instead of ad-hoc code
      dpkg: Update list of binaries to check on PATH
      dpkg-deb: Pass last the node to add to add_to_filist
      dpkg-deb: Rename _finfo struct to file_info
      dpkg-deb: Refactor file info structure creation into a new function
      dpkg-deb: Check and warn on duplicate conffiles
      Move pkg-array to libdpkg
      libdpkg: Create a new pkg_list structure and functions
      Switch ad-hoc code to use struct pkg_list data type
      Move PARTSDIR macro from libdpkg to dpkg-split
      Move LISTFILE macro from libdpkg to dpkg
      Make the build silent by default
      dpkg-query: Remove unused f_ and fc_ variables
      Fix small leak when parsing ‘--ignore-depends’ option values
      Use varbuf instead of ad-hoc handling of growing strings
      Split deferred_configure conffile handling into its own function
      Move development documentation to doc/
      Rename autoconf auxiliary directory from config to build-aux
      s-s-d: Remove wrong comment not matching with code
      build: Add new DPKG_CHECK_DECL m4 macro
      libcompat: Define WCOREDUMP only if the system does not have it
      build: Do not use single quote on strings
      build: Do not use backticks on m4 macros
      dpkg-deb: Remove S_ISLNK compatibility definition
      libdpkg: Use char instead of unsigned char for strings
      dpkg-deb: Use void * instead of unsigned char * for read/write buffer
      libdpkg: Do not allocate memory for buffer md5 hash result
      libdpkg: Use internerr for invalid buffer data types
      libdpkg: Move buffer_arg declaration directly into buffer_data
      libdpkg: Rename struct buffer_data data member to arg
      libdpkg: Make buffer_write buf argument const
      libdpkg: Add new buffer_hash and buffer_md5 functions
      libdpkg: Use struct buffer_data instead of buffer_data_t
      s-s-d: Call warning instead of fatal on ioprio_set error
      Clean up coding style for half compliant files
      Use warning() instead of fprintf() in checkpath()
      Do not print redundant dpkg prefix and new line on undefined PATH
      build: Properly escape $( inside perl regex
      build: Wrap perl expression in PERL_LIBDIR assignment
      build: Refactor warning flags into a new WFLAGS variable
      build: Update compiler-warnings flags
      libdpkg: Enclose buffer_data union initialization with braces
      build: Fix build failure with automake < 1.11
      Remove unused variables
      dpkg-trigger: On --help print the default admindir
      dpkg-trigger: Move functions and variables around
      Remove helponly and versiononly functions
      build: Reorder subdirectory build sequence
      build: Add test for 'trailing comma in enum' C99 support
      dpkg-query: Do not use C99 style for-loop variable declarations
      build: Do not test for C99 for-loop variable declaration support
      build: Add an explicit return type to main in DPKG_FUNC_VA_COPY
      build: Use memcpy instead of assignment to copy va_list
      build: Check for C99 snprintf family of functions
      build: Add more options to try to get support for C99 extensions
      build: Abort if there is no support for the required C99 extensions
      Switch to use stdbool were appropriate
      dpkg: Use more meaningful and clearer variable names in checkpath()
      dpkg: Use size_t instead of long for path_len in checkpath()
      dpkg: Reduce variable scope in checkpath
      Add document describing the C coding style
      statdb: Do stricter parsing validation
      dpkg-statoverride: Rewrite in C
      libdpkg: Add new varbuf_grow function
      libdpkg: Use varbuf_grow instead of increasing member used
      libdpkg: Fix varbufprintf to not grow indefinitely
      dpkg: Use stat size to varbuf_grow the buffer for readlink
      libdpkg: Use varbuf_grow instead of varbufextend
      libdpkg: Remove unused varbufextend
      Add a .mailmap file to fix up name and mail addresses
      Add all libdpkg .c files to POTFILES
      dpkg-statoverride: Add missing angle brackets in string
      libdpkg: Mark and improve strings for translation
      libdpkg: Rename pkglistqsortcmp to pkg_sorter_by_name
      libdpkg: Move pkg_sorter code to a new pkg module
      build: Fix DPKG_CHECK_DEFINE to properly check for dpkg_cv_define_$1
      build: Properly escape DPKG_CHECK_DECL and DPKG_CHECK_DEFINE arguments
      libcompat: Define offsetof only if the system does not have it
      libdpkg: Make path_quote_filename s argument const
      libdpkg: Change path_quote_filename size argument type to size_t
      libdpkg: Change order and rename path_quote_filename arguments
      libdpkg: Update path_quote_filename function comment
      Do not use C++ style comments in C code
      Use named intializers in structures
      libdpkg: Expand TKI_DEFINE macro for each user
      dpkg-statoverride: Add missing newline in --version output
      dpkg-statoverride: Add missing values for option flags
      dpkg-statoverride: Fix typo inverting the override exists check
      dpkg-statoverride: Fallback to printing #<id> if db lookup fails
      libdpkg: Rename symlinkList variables in TarExtractor()
      dpkg: Remove unused head variable in getselections()
      libcompat: Handle 0 size case for C99 vsnprintf semantics
      dpkg: Remove unused variable current in pkg_files_add_file()
      man: Fix typo in Swedish translation making build to fail
      libcompat: Always add an empty file to the libcompat static library
      Add .mailmap to EXTRA_DIST
      Remove unused <fnmatch.h> include
      Sort order of header includes
      Generate the autoconf version from git
      doc: Add doxygen support
      Document some of the code with JavaDoc
      build: Rename and namespace dpkg m4 files
      build: Only use po4a if present and if NLS is enabled
      Update TODO list
      build: Use pkg-config m4 macros to detect selinux library
      Fix spelling errors in the Catalan translation
      libdpkg: Namespace include guards with LIBDPKG instead of DPKG
      libdpkg: Rename and namespace subproc related functions
      Rename process description function arguments to desc
      libdpkg: Split process waiting from subproc_wait_check into subproc_wait
      Use subproc_wait instead of directly calling waitpid
      dpkg: Do not bogusly ignore find exit code 1
      libdpkg: If PROCNOERR in subproc_check() return the status code
      Use find with -L instead of deprecated -follow
      libdpkg: Make desc argument const in compress_cat and decompress_cat
      dpkg: Call standard_shutdown after invoking the post hooks
      libdpkg: Remove unused dumpchain macro
      Replace FSF address by pointing to the gnu.org URL
      Unify text in license headers
      Fix copyright statements
      Unify format in license headers
      Add missing license headers
      Expand text in license header for unversioned GPL
      Clean up perl shebang line
      dpkg: Refactor filename summarizing into a new function
      dpkg-deb: Fix a file descriptor leak
      libcompat: Fix resource leaks on error conditions in scandir
      libcompat: Do not preallocate list before the loop in scandir
      dpkg: Remove unused variable in ensure_diversions()
      dpkg: Remove redundant ferror check in ensure_diversions()
      dpkg: Fix checkpath() to use varbuf instead of m_malloc
      Add new status-fd action when disappearing a package
      dpkg: Pass struct pkginfo instead of the package name to log_action
      dpkg-statoverride: Add missing angle bracket in string
      Merge branch sid (through commit '1.15.4.1')
      dpkg-buildpackage: Do not list supported compressors in --help output
      dpkg-source: Check if the opmode option is defined before use
      man: Update modification dates
      The changelog police is back
      build: Add debian/source/ files to EXTRA_DIST
      scripts: Update objdump.tags files
      Regenerate .pot files and merge .po files with them
      Release 1.15.5

Helge Kreutzmann (16):
      Update German scripts translation
      Update German translation of manual pages
      Update German scripts translation
      Update German translation of manual pages
      Fix typo in man page: s/invokation/invocation/
      Update German scripts translation
      Update German translation of manual pages
      Update German scripts translation
      Minor fixes in the German man page translation
      Fix typo
      Update German translation of manual pages
      Fix typos
      Update German scripts translation
      Update German scripts translation
      Update German translation of manual pages
      Update German translation of manual pages

Jonathan Nieder (3):
      debian/copyright: Update path to MD5 code
      libdpkg: fix misspelling of __attribute__((const))
      man: Fix a small typo in dpkg.1

Mikhail Gusarov (1):
      libcompat: Add top_builddir to the include path

Milo Casagrande (2):
      Italian translation update
      Italian translation update

Miroslav Kure (1):
      Czech translation update

Peter Krefting (2):
      Update Swedish translation.
      Update Swedish translation.

Raphael Geissert (1):
      dpkg-split: Fix a directory stream leak

Raphaël Hertzog (97):
      Add versioned dependency on base-files (>= 5.0.0) to dpkg-dev
      Fix bad bug number
      Add deb-extra-override(5) to dpkg-dev
      Update Standards-Version to 3.8.3 (no changes needed).
      Rename Dpkg::Control in Dpkg::Control::Info
      Rename Dpkg::Cdata into Dpkg::Control
      Dpkg::Control: new object interface
      Use the new Dpkg::Control interface everywhere
      Drop unused code that has been merged in Dpkg::Control
      Dpkg::Control::Fields: official list of control fields
      Dpkg::Control: define the default output order based on the type
      Replace old capit() by field_capitalize() everywhere
      Get rid of Dpkg::Deps @src_dep_fields @pkg_dep_fields and %dep_field_type
      dpkg-genchanges, dpkg-gencontrol: do not hardcode the field output order
      Drop Dpkg::Fields and convert everything to Dpkg::Control::Fields
      Add vendor hook to register custom fields
      Register field Dm-Upload-Allowed as Debian specific
      dpkg-scanpackages: simplify by using the Dpkg::Control object
      dpkg-scansources: simplify by relying more on the Dpkg::Control object
      debian/changelog: document recent changes in perl API
      Dpkg::Control::Fields: don't fail when vendor hook is not (well) implemented
      Dpkg::Changelog: add new vendor hook post-process-changelog-entry
      Dpkg::Vendor::Ubuntu: register custom field Launchpad-Bugs-Fixed
      Dpkg::Vendor::Ubuntu: move Launchpad-Bugs-Fixed creation in another hook
      Dpkg::Vendor::Default: recommend use base for child objects
      Dpkg::Vendor::*: better handle unknown hooks
      dpkg-genchanges, Dpkg::Vendor::Default: drop hook before-changes-creation
      Integrate dpkg-ftp into dselect
      dselect-ftp: Update my e-mail address and copyright
      dselect-ftp: don't use obsolete dpkg --print-installation-architecture
      dselect-ftp: stop calling dpkg --forget-old-unavail as it's a no-op
      Fix the polish translation.
      Dpkg::Control::Fields: add Priority and Section fields to CTRL_APT_SRC
      dpkg-scanpackages/dpkg-scansources: support compressed override files
      dpkg-scanpackages: add new --medium option
      Integrate dpkg-multicd into dselect
      dselect-multicd: add missing copyright statements
      dselect-multicd: update README wrt the dpkg-scanpackages situation
      dselect-multicd: replace/drop obsolete dpkg commands
      dselect-multicd: fix bashism in setup script
      Dpkg::Version: new implementation and new object interface
      Update all Perl modules and scripts to use the new Dpkg::Version API
      Dpkg::Version: drop the old API and implementation
      Ensure that the string representation of Dpkg::Version is unchanged
      Dpkg::Version: rename some functions and constants
      Dpkg::Deps::version_implies(): fix to return undef with invalid versions
      Dpkg::Changelog::Debian: store unmodified changes lines in an array
      Dpkg::Changelog::Debian: keep blank lines and trailing whitespace unchanged
      Dpkg::Changelog::Debian: preserve blank lines
      Dpkg::Control: rename CTRL_APT_* to CTRL_INDEX_*
      Dpkg::Compression: add support for xz compression method
      Dpkg::Control::Fields: allow transfer of custom fields
      Dpkg::Changelog::find_closes(): don't return duplicate bug numbers
      debian/rules: use “$(MAKE)” instead of “make”
      Dpkg::Index: new module
      Dpkg::Changelog::Entry, Dpkg::Control::Changelog: new modules
      Update Dpkg::Changelog to use new ::Entry modules
      Move parse_changelog() to a separate module Dpkg::Changelog::Parse
      Drop compatibility with old changelog parsers (as planned)
      Dpkg::Changelog::Entry::Debian: parse changes lines as set of items
      Move header/trailer checks in Dpkg::Changelog::Entry::Debian
      Dpkg::Changelog::Debian: use constants for parser states
      Dpkg::Changelog::Debian: drop improper documentation
      Dpkg::Changelog: don't use English
      Dpkg::Changelog::Debian: syntax/style cleanup
      Move find_closes() into Dpkg::Changelog::Entry::Debian
      dpkg-parsechangelog: drop useless “use” statements
      Dpkg::Changelog::Entry: add get_dpkg_changes() method here
      Dpkg::Changelog: completely update the API
      Add supplementary non-regression tests for Dpkg::Changelog related modules
      Add changelog entry for Dpkg::Changelog changes
      Add missing bug closure
      Dpkg::Changelog::get_range(): fix return value when range is empty
      Dpkg::Source::Package::V2:do_build(): fix binary file check
      Dpkg::Source::Package::V2::do_build(): improve matching of ignored files
      Add missing bug closure.
      Dpkg::Source::Package::V3::git::do_build(): remove extra quotes
      Dpkg::Control::Hash: use lower-case internally for keys
      Dpkg::Control::Hash: handle arbitrary field values
      Stop using the English perl module
      dpkg-source: optimize diffing phase of a source package build
      update-alternatives: fix a french translation
      Dpkg::Source::Patch::add_diff_directory(): small optimization
      dpkg-source: add new --print-format command
      dpkg-source: split usage string in several translatable strings
      Dpkg::Conf: new module to parse options from a configuration file
      dpkg-source: read sticky options from <dir>/debian/source/options
      dpkg-source: list upstream files modified by the diff during extraction
      dpkg-source: list upstream files modified by the diff during build
      dpkg-source(1): indicate the recommended source formats
      dpkg-source: add a DEP-3 compliant header to automatic patches
      Use source format "3.0 (native)" with bzip2 compression for dpkg itself
      Regenerate .pot files and merge .po files with them
      dpkg-deb: fix typo unkown -> unknown
      dpkg-source: parse only long options from debian/source/options
      Dpkg::Conf: fix parsing of options with values
      debian/source/options: use long option name as per new syntax

Sean Finney (5):
      libdpkg: Move quote_filename to the path module as path_quote_filename
      libdpkg: Move copyfileperms to non-static file_copy_perms
      doc: Tune some Doxygen settings
      dpkg: Pass a pkginfo structure to promptconfaction()
      dpkg: Add JavaDoc comments for promptconfaction()

Sven Joachim (4):
      German dselect translation update
      German dpkg translation update
      German dpkg translation update
      German dpkg translation update

Wiktor Wandachowicz (3):
      Update polish programs translations
      Update Polish translation of scripts
      Update Polish translation of dselect

-----------------------------------------------------------------------

No new revisions were added by this update.

-- 
Alioth's /usr/local/bin/git-commit-notice on /srv/git.debian.org/git/reproducible/dpkg.git



More information about the Reproducible-commits mailing list