[Build-common-hackers] Bug#521180: Bug#521180: cdbs: DEB_PYTHON_MODULE_PACKAGE behavior changed unexpectedly

Jonas Smedegaard dr at jones.dk
Wed Mar 25 14:58:22 UTC 2009

Hash: SHA1

On Wed, Mar 25, 2009 at 03:15:42PM +0100, Marc Dequènes (Duck) wrote:
> Until 2008-03-17, at least, DEB_PYTHON_MODULE_PACKAGE was always defined 
> with the following code:
>   DEB_PYTHON_MODULE_PACKAGE = $(firstword $(filter-out %-doc %-dev  
> %-common, $(DEB_PACKAGES)))
> and is now unset by default.
> I didn't find anything documenting this changes in the changelog or  
> NEWS.Debian. This is problematic, as this breaks packages relying on  
> this variable in the build rules, like in the 'balazar' package:
> Several package then FTBFS, thus the severity of this bug.
> It seems the 'cdbs_python_packages' variable could replace it, but the  
> plural in the name suggest it would not.
> We could perhaps raise this problem on the mailing-list before 
> changing or reverting the behavior again.

cdbs_python_packages is indeed the replacement: In the past multiple 
packages was supported, and I have prepared for that to be supported 
again in the future, even if currently i is not possible.

I made sure to support packages _overriding DEB_PYTHON_MODULE_PACKAGE, 
but overlooked the possibility of packages using that variable for other 
purposes :-/

The reason I didn't just keep it was (if I recall correctly) that I 
could find no way to deprecate it as has been done with other variables, 
spitting out a warning for some time until we finally drop it 

I agree that current situation is not acceptable.

  - Jonas

- -- 
* Jonas Smedegaard - idealist og Internet-arkitekt
* Tlf.: +45 40843136  Website: http://dr.jones.dk/

  [x] quote me freely  [ ] ask before reusing  [ ] keep private
Version: GnuPG v1.4.9 (GNU/Linux)


More information about the Build-common-hackers mailing list