[Debian-eeepc-devel] boot halts when SD card is inside slot

Pedro Gapski pbgapski at gmail.com
Fri Aug 1 18:03:15 UTC 2008

hi all,

I have been hit by a weird problem, and I hope someone can help me
understand what is going on and maybe put some light on it. Please be kind
to me if this is not the right list to ask ;-)

I run debian testing on my eee pc 701. The box has one sd slot, and I have a
transcend 16Gb sd card on it. When the card was new and empty, the system
would boot with no problems with the card inside the slot. However, after I
started writing to it, when I boot the system, it halts after hal starts
with a read error on the card, and a hard boot is required. If I boot
without the card in, everything goes fine.

My first guess was a bad sd card. I reformated it, used badblocks -w on it,
and no problems were found. After the card was formated (and empty), the
system would boot without problems.

However, as soon as I started writing to it, when I reboot I get the same
read errors again.

If, however, I plug the card after system boot, I can use it without
problems. I just tried to read it all to make sure:

gapski at revo:~$ dd bs=1024  if=/dev/sdb of=/dev/null
15694336+0 records in
15694336+0 records out
16071000064 bytes (16 GB) copied, 967.822 s, 16.6 MB/s

Any ideas? I would love to understand what is going on here...

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.alioth.debian.org/pipermail/debian-eeepc-devel/attachments/20080801/e2ae5bd6/attachment.htm 

More information about the Debian-eeepc-devel mailing list