[debian-yeeloong-project] Yeeloong X crash (was "root filesystem and fsck fail during initial boot")

Advrk Aplmrkt avkaplmkt at gmail.com
Mon Nov 28 01:52:09 UTC 2011

On 27 November 2011 13:44, Michael Dorrington
<michael.dorrington at gmail.com> wrote:
> On 23/11/11 15:43, Advrk Aplmrkt wrote:
>> Hello,
>> I've followed the wiki instructions
>> (http://wiki.debian.org/DebianYeeloong/HowTo/Install#Squeeze_X) to
>> install Wheezy on my new Lemote Yeeloong last night by downloading and
>> using the latest files at:
>> http://d-i.debian.org/daily-images/mipsel/daily/loongson-2f/netboot/
>> The installation went well, but during initial boot I get the
>> following error during "Checking root file system...fsck from
>> util-linux 2.19.1":
>> fsck died with exit status 4
>> It then gave me the option to run fsck manually in the maintainence
>> shell, but after running fsck I still get the same error upon
>> reboot.....
>> I tried reinstalling the whole system, both times using guided
>> partitioning, but same problem.
>> The only thing I did not explicitly specified in the HowTo is choosing
>> the 3.1.0-1-loongson-2f kernel, but is this the problem?
>> Please help, I am eager to get this to work.
>> Thanks!!
> Wheezy isn't released as stable yet and those daily install images may
> well not work on any particular day.
> You might like to try one or more of the following:
> * Try again will the current available build as it might have been
>  fixed.
> * Submit a bug report on the failing wheezy loongson-2f install.
> * Try to install squeeze instead.
>  - http://wiki.debian.org/DebianYeeloong/HowTo/Install#Squeeze
>  - If you want you can then upgrade to wheezy from the squeeze install.
> * On the wheezy system when in the GRUB bootloader (or PMON?) add:
>  fastboot
>  to the kernel args line which will make Debian skip an fsck on boot.
>  Not sure what whether this will result in booting into a working
>  system though.
> Regards,
> Mike.

Thanks for your suggestions, I tried and was successful in installing
Squeeze, then upgrading it to Wheezy!

However, even after carefully following the X rebuild instructions
including the devscripts part, I get an segmentation fault when I try
to start X. Please see screenshot here:


The segmentation fault/error is not exactly the one reported in bug
#594684 (http://bugs.debian.org/594684), so I am not sure if it is a
problem with how I followed the instructions??? I've already rebuilt
again, but still same problem.

Thanks for your help so far, please let me know how I can troubleshoot
this problem. Thanks!

More information about the debian-yeeloong-project mailing list