[debian-yeeloong-project] Project status?

Stuart Longland stuartl at longlandclan.id.au
Sun Oct 30 08:01:47 UTC 2016

Hi all,

I recently decided to dust off my old Yeeloong that was gathering dust, 
and so far have managed to dig up network boot images for the Jessie 
release of Debian.

With some argument, I've managed to get a desktop going.  Notably I 
wanted a decent web browser so I can look up maps, weather information, 
check email and anything else I might need on-the-road.

First observations so far:
- Firefox bombs out with 'Illegal Instruction'
- xserver-xorg-video-siliconmotion causes a segmentation fault
- RTL8187B scanning is broken in kernel 4.8.5

1. Firefox bombing out.

Basically, the application doesn't even start.  Running on the command 
line, it'll bomb out with SIGILL shortly after starting.  This used to 
work fine on the Yeeloong.  The backtrace is less than helpful:
> (gdb) r
> Starting program: /usr/bin/firefox-esr
> warning: GDB can't find the start of the function at 0x6b1bdf20.
>     GDB is unable to find the start of the function at 0x6b1bdf20
> and thus can't determine the size of that function's stack frame.
> This means that GDB may be unable to access that stack frame, or
> the frames below it.
>     This problem is most likely caused by an invalid program counter or
> stack pointer.
>     However, if you think GDB should simply search farther back
> from 0x6b1bdf20 for code which looks like the beginning of a
> function, you can increase the range of the search using the `set
> heuristic-fence-post' command.
> Program received signal SIGILL, Illegal instruction.
> 0x6b1bdf20 in ?? ()
> (gdb) bt
> #0  0x6b1bdf20 in ?? ()

My workaround is to use Konqueror, which at least works well enough. 
Firefox is preferred though.

2. SiliconMotion driver

This was a problem on Gentoo too, and the Debian Wiki page mentions a 
patch.  I cobbled together a Debian package that included that patch, 
but it still segfaults, so I'm missing something there.

Workaround so far: blow away the offending .so blob in the 
xserver-xorg-driver-siliconmotion package, which means X falls back to 
the less performant, but at least working, fbdev driver.


I'm attempting to bisect the kernel releases to see where the problem 
first appeared.  WIFI works fine with the standard Debian kernel, and 
also worked on Gentoo under kernel 3.17.

If people are interested, I can share my .config which at least gets 
these things booting with a usable configuration.  I'm a little miffed 
though that there's no mention of Loongson 2F in the 'sid' distribution, 
otherwise I would have tried a kernel from there first.

4. ISA level

I note the following notice on the Yeelong page: Debian Stretch and 
later versions of Debian will not support MIPS ISA level used on 
Loongson-2F based Lemote Yeeloongs.

That begs the question, what ISA level are they planning on supporting? 
The Yeeloong is good to MIPS3, and will run 64-bit ABIs fine.  This time 
last week I was running Gentoo with N32 ABI on this machine, the only 
thing that made me go Debian was the realisation that this machine being 
no speed demon, it was going to take a very long time to get everything 
running, and I really need this machine to work.  I admire Gentoo's 
flexibility, but this is not essential.

Can anyone clarify what the long-term plans for this port?
Stuart Longland (aka Redhatter, VK4MSL)

I haven't lost my mind...
   ...it's backed up on a tape somewhere.

More information about the debian-yeeloong-project mailing list