[debian-yeeloong-project] Project status?

Roman Mamedov rm at romanrm.net
Sun Oct 30 09:37:14 UTC 2016

On Sun, 30 Oct 2016 18:01:47 +1000
Stuart Longland <stuartl at longlandclan.id.au> wrote:

> 1. Firefox bombing out.
> Basically, the application doesn't even start.  Running on the command 
> line, it'll bomb out with SIGILL shortly after starting.  This used to 
> work fine on the Yeeloong.

Did not try Jessie yet, but yeah the Iceweasel version from Wheezy doesn't
appear to have this issue.

> 2. SiliconMotion driver
> This was a problem on Gentoo too, and the Debian Wiki page mentions a 
> patch.  I cobbled together a Debian package that included that patch, 
> but it still segfaults, so I'm missing something there.
> Workaround so far: blow away the offending .so blob in the 
> xserver-xorg-driver-siliconmotion package, which means X falls back to 
> the less performant, but at least working, fbdev driver.

The direction to experiment here might be to try the more optimized
framebuffer driver called fbturbo: https://github.com/ssvb/xf86-video-fbturbo
Someone could improve that one by implementing the use of Loongson multimedia
instructions there, in addition to its current ARM NEON/VFP.

> 3. WIFI
> I'm attempting to bisect the kernel releases to see where the problem 
> first appeared.  WIFI works fine with the standard Debian kernel, and 
> also worked on Gentoo under kernel 3.17.

I did not check scanning specifically, but I have a terribly slow upload issue
using the new kernels (around 10-20 kilobytes/sec only), compared to ~1 MB/sec
with my old 3.6.9 kernel. Download speeds are mostly unaffected. Unfortunately
the corresponding driver was heavily reworked at some point in between, so it
may not be trivial to find heads or tails of what causes the actual problem.

> If people are interested, I can share my .config which at least gets 
> these things booting with a usable configuration.  I'm a little miffed 
> though that there's no mention of Loongson 2F in the 'sid' distribution, 
> otherwise I would have tried a kernel from there first.

I vaguely remember Debian's stock loongson2f kernel not booting for me, what I
did was download the vanilla kernel from kerner.org and apply
"Loongson-community" patchset to it:
Some of the changes in it appear to be fairly important and make you wonder
how the stock kernel is even supposed to work without those.

With respect,

More information about the debian-yeeloong-project mailing list