[PKG-OpenRC-Debian] Bug#819258: Bug#819258: openrc: dependency resolving fails using init-system-helpers

Benda Xu heroxbd at gentoo.org
Sun Mar 27 17:11:37 UTC 2016


Thanks for the report.

Kevin Velghe <kevin at paretje.be> writes:

> On Sat, Mar 26, 2016 at 03:02:00AM +0100, Adam Borowski wrote:

>> I've tried multiple scenarios but failed to reproduce your problem.
>> Including dist-upgrades:
>>   jessie sysv-rc -> unstable -> openrc
>>   jessie sysv-rc -> openrc -> unstable
>> So there's something more complex on your system than just lvm2.  Letting us
>> know what might be helpful in trying to find out what's amiss for
>> you.

I cannot reproduce the bug by installing lvm2 on sid or jessie.

> The problem at boot might be related to the fact /boot is located on a
> lvm partition, otherwise I can't think about anything.
> OK, I'll check the installation problem on a container later, but if I
> install sysv-rc or current openrc package, then the installation of lvm2
> fails because the dependencies aren't enabled. 

> Yesterday, I upgraded lvm2. During the upgrade, I got the following error:
>  insserv: Service mountdevsubfs has to be enabled to start service lvm2
>  insserv: exiting now!

> This was fixed by manually enabling mountdevsubfs using insserv, after
> which I could finish upgrading. 

Why was mountdevsubfs not enabled?

Could you please paste the output of "ls -l /etc/rc*.d/*mountdev*" and
"rc-update | grep mountdev"?

On my system, they produce:

# ls -l /etc/rc*.d/*mountdev*
lrwxrwxrwx 1 root root 26 Feb 18 23:16 /etc/rcS.d/S02mountdevsubfs.sh -> ../init.d/mountdevsubfs.sh

# rc-update | grep mountdev
     mountdevsubfs.sh |                                    sysinit

> This morning however, booting hanged at lvm.

Did it hang with openrc?

> Downgrading lvbm2 didn't solve the problem, so I tried booting using
> sysv-rc, which had the same problem. systemd booted well, as did
> openrc 0.20.4-1.

Didn't openrc+lvm2 hang? Confused:(

>> As you say that sysv-rc failed too, it doesn't sound like anything related
>> to openrc.

> Yes, it is related to openrc, as openrc seems only affected because of
> the use of init-system-helpers to provide update-rc.d, which does not
> seem to use openrc to determine the dependencies.

The new update-rc.d from init-system-helpers calls rc-update to handle
the runlevels for openrc.  It is different from the old update-rc.d
shipped with openrc only in that it also calls insserv, too.

So the question really becomes: is your mountdevsubfs.sh enabled?

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 818 bytes
Desc: not available
URL: <http://lists.alioth.debian.org/pipermail/openrc-devel/attachments/20160328/e4d39970/attachment.sig>

More information about the OpenRC-devel mailing list