[PKG-OpenRC-Debian] Bug#819258: openrc: dependency resolving fails using init-system-helpers

Kevin Velghe kevin at paretje.be
Sat Mar 26 17:14:44 UTC 2016

On Sat, Mar 26, 2016 at 03:02:00AM +0100, Adam Borowski wrote:
> On Fri, Mar 25, 2016 at 06:05:44PM +0100, Kevin Velghe wrote:
> > Yesterday, I upgraded lvm2. During the upgrade, I got the following error:
> >  insserv: Service mountdevsubfs has to be enabled to start service lvm2
> >  insserv: exiting now!
> > 
> > This was fixed by manually enabling mountdevsubfs using insserv, after
> > which I could finish upgrading. This morning however, booting hanged at
> > lvm. Downgrading lvm2 didn't solve the problem, so I tried booting using
> > sysv-rc, which had the same problem. systemd booted well, as did openrc
> > 0.20.4-1.
> > 
> > So it seems openrc is able to handle the dependencies well, but that the
> > current init-system-helpers does at least part of the work the sysv-rc
> > way, which seems unable to handle it.
> I've tried multiple scenarios but failed to reproduce your problem.
> Including dist-upgrades:
>   jessie sysv-rc -> unstable -> openrc
>   jessie sysv-rc -> openrc -> unstable
> So there's something more complex on your system than just lvm2.  Letting us
> know what might be helpful in trying to find out what's amiss for you.
OK, indeed, if I install lvm2 on a clean unstable install with openrc
the installation works well. But, if I do the same using rm -r
/etc/rc?.d; insserv -d /etc/init.d, which is what you will do when
upgrading from an old version of openrc, I get the reported error. It
does boot however, but that's probably because there are no partitions.
> > I'm sorry if this should have been reported to init-system-helpers, I
> > wasn't sure as it is openrc-specific.
> As you say that sysv-rc failed too, it doesn't sound like anything related
> to openrc.
> Meow!
> -- 
> A tit a day keeps the vet away.
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 819 bytes
Desc: Digital signature
URL: <http://lists.alioth.debian.org/pipermail/openrc-devel/attachments/20160326/f6f8e0ae/attachment.sig>

More information about the OpenRC-devel mailing list