[Pkg-gpe-maintainers] libgpewidget update?

Neil Williams codehelp at debian.org
Wed Jun 18 16:09:42 UTC 2008

On Wed, 2008-06-18 at 17:32 +0200, Moray Allan wrote:
> > Just uploaded gpe-todo 0.51-1 to ftp-master.
> > 
> > Not sure what to do with libgpewidget - Policy 8.2 has been modified
> > such that we should really have libgpewidget-tools or libgpewidget-data
> -tools sounds odd unless the package has some user-runnable tool, that
> sentence is about 'run-time support programs' rather than all support
> files.

True - translations are "run-time support data" and these files would
need a Replaces: if and when libgpewidget2 is released - if they are
moved before libgpewidget2 is available, there is no need for a Replaces
(I read that as the intention of the Policy change.)

I'll use libgpewidget-data after Lenny.

> > That means a NEW package and with the library freeze coming up by the
> > end of this month, I'm undecided whether to upload 0.116 and only update
> > the Standards Version after Lenny or leave 0.116 itself until after
> > Lenny.
> > 
> > The fixes in 0.116 are related to cairo support which we already work
> > around in 0.115 (this workaround is removed in 0.116). 0.116-1 also
> > includes numerous lintian fixes but those are minor. (Mainly to do with
> > the clean target and removing generated changes from the .diff.gz.) If I
> > leave Standards Version at 3.7.3, 0.116-1 is lintian clean now.
> The d-d-a announcement of the updated policy explicitly said that these
> policy updates weren't targets for lenny, so I expect the Release
> Managers would be happier if any extra package waited. 


>  From what you
> say 0.116 could be as well to wait too, especially if the shlibs
> file/resulting dependencies will need bumped.  (Though I see we're
> almost completely in sync between testing and unstable already, so a
> shlibs bump shouldn't be a big problem just now.)

libgpewidget1.symbols should deal with those problems - it goes all the
way back to 0.88. Applications and libraries using libgpewidget symbols
should get the lowest supported dependency according to the symbols
$ dpkg -l libgpewidget1
ii  libgpewidget1                 0.116-1

But the uploaded version of gpe-todo 0.57 depends on:
libgpewidget1 (>= 0.115)

and gpe-expenses depends on 0.88:

libgpewidget1 (>= 0.88)

There are no changes to libgpewidget1.symbols in 0.116.


Neil Williams

-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 197 bytes
Desc: This is a digitally signed message part
Url : http://lists.alioth.debian.org/pipermail/pkg-gpe-maintainers/attachments/20080618/6085c816/attachment.pgp 

More information about the Pkg-gpe-maintainers mailing list