[Pkg-hpijs-devel] Bug#463814: Hplip fails to recognize correctly installed devices

David Baron d_baron at 012.net.il
Sun Jul 13 05:12:29 UTC 2008

On Sunday 13 July 2008 01:08:18 Bruce Sass wrote:
> On Sat July 12 2008 02:19:33 pm David Baron wrote:
> > The 2.4* and newer packages from Debian Sid do not find the printer
> > at all so are not working correctly.
> I am a bit confused...
> The hp-check.log you sent on June 15th showed that HPLIP did
> indeed "find the printer", and that log was generated by HPLIP-2.8.5
> which is newer than "2.4*".
> ...so, your statement which I have included above appears to be
> incorrect.
> Like it says in your hp-check.log:
> ---
> hp-check[9601]: info: :Printer status: printer HP690C is idle.  enabled
> since Thu 15 May 2008 07:31:55 PM IDT
> "warning: Printer is not HPLIP installed. Printers must use the hp: or
> hpfax: CUPS backend to function in HPLIP."
> ---
> The errors you mention in your original report are to be expected with
> the configuration indicated in the hp-check.log you have provided.
> There is nothing buggy with that behaviour; the utilities expect hp:
> and hpfax: URIs and since none exist they don't find any usable
> devices, the toolkit finds no devices for the same reason.
> From a bug report point of view, and taking the additional info into
> account, this is the interesting bit in your original message:
> "So I try to configure the device, go through all the steps and
> on "finish", am back with no devices or unsupported device."
> Later on you said:
> "I tried changing that to one with HP stuff in it."
> That is the setup (the one with an hp: type device URI) we need to see
> the hp-check.log and actual error messages/reports for. It may well be
> something as simple as a missing underscore in the URI.

I am confused here.

The listings for both the HP and the Epson printers (which cannot be around at 
the same time! is coming from cups. If I attempt to probe the lp0: printer 
from hplip, it will not detect it. The very old version of hplip (from stable) 
did detect it and enabled me to try the functions (that the printer does not, 
in fact use).

Both printers are installed via cups. I switch the lp0: between them.

The URIs were assigned by the cups setup. I manually edited the 
/etc/cups/printers.conf and changed the parallel: prefix to hp:. This did not 
help hplip and the printers no longer worked. There are no underscores, just 

Since the older (stable) version worked, I filed this bug. The suggestion was 
not mine but an earlier poster who found a similar problem.

More information about the Pkg-hpijs-devel mailing list