[Pkg-ime-devel] Bug#747375: ibus-daemon does not start - no engine set and has no icon and cannot be run from command line

Osamu Aoki osamu_aoki_home at nifty.com
Thu May 8 12:29:45 UTC 2014


On Wed, May 07, 2014 at 10:19:01PM -0400, Dean Chia wrote:
> Package: ibus
> Version: 1.5.5-1
> Severity: important

I have
ii  ibus           1.5.5-1      amd64        Intelligent Input Bus - core
> ibus does not work and has not worked for a long time. I am a sid user. 

Same here and ibus working OK here with GNOME3 started by GDM3.  What DE
do you use.

> I have
> uninstalled a long while ago and have reinstalled recently. It does not start; there is
> no menu, and I cannot even run it from the command line. If I run it in terminal and
> type "ibus engine" I receive the following:

I added few IMs via GNOME&s menu and tested.

$ ibus engine
$ ibus engine
$ ibus engine
$ ibus engine

> (process:17576): IBUS-CRITICAL **: ibus_bus_get_global_engine: assertion 'IBUS_IS_BUS
> (bus)' failed No engine is set.
> I originally had problems with the ibus-pinyin and the Chinese in ibus-m17n. But I have
> not even got to try it yet, as ibus won't start. Thank you.

I used to use ibus with ibus-anthy.  Now I am using it with ibus-kkc
(not yet in unstable).

So we use different engin.

ibus-pinyin has bug
  #746969 [src:ibus-pinyin] ibus-pinyin depends on Gobject Introspection
 ==> Can you install gobject-introspection package?

I have both ibus-m17n and ibus-pinyin installed.  So they should not
break system foy you.

If you are using ibus-setup to set, it may not be working... I did not
use it.


More information about the Pkg-ime-devel mailing list