[Pkg-ime-devel] Bug#747375: ibus-daemon does not start - no engine set and has no icon and cannot be run from command line

Dean Chia 贾定 peridox91 at gmail.com
Thu May 8 14:15:53 UTC 2014

I use Gnome3 - the standard that comes with Debian Sid.

The ibus icon is now showing up in my gnome-task-panel on top. My engine is
now registered as m17n:zh:py. Unfortunately, it still cannot type Chinese.
And when I restarted my computer and did ibus-setup to start ibus-daemon
(still no icon in Gnome Shell), it turned on ibus but than that replaced my
normal keyboard input switches (I use US-Dvorak International, TIRO Hebrew,
and Greek), so I had to re-activate them by removing and re-adding a
keyboard back in System Settings --> Keyboard.

I tried uninstalling and reinstalling ibus-pinyin as well as
ibus-googlepinyin. However, it seems that there is no engine that drives my
Chinese. All I get is more English.

On Thu, May 8, 2014 at 8:29 AM, Osamu Aoki <osamu_aoki_home at nifty.com>wrote:

> Hi,
> On Wed, May 07, 2014 at 10:19:01PM -0400, Dean Chia wrote:
> > Package: ibus
> > Version: 1.5.5-1
> > Severity: important
> I have
> +++-==============-============-============-=================================
> ii  ibus           1.5.5-1      amd64        Intelligent Input Bus - core
> > ibus does not work and has not worked for a long time. I am a sid user.
> Same here and ibus working OK here with GNOME3 started by GDM3.  What DE
> do you use.
> > I have
> > uninstalled a long while ago and have reinstalled recently. It does not
> start; there is
> > no menu, and I cannot even run it from the command line. If I run it in
> terminal and
> > type "ibus engine" I receive the following:
> I added few IMs via GNOME&s menu and tested.
> $ ibus engine
> kkc
> $ ibus engine
> m17n:ja:tcode
> $ ibus engine
> pinyin
> $ ibus engine
> libpinyin
> > (process:17576): IBUS-CRITICAL **: ibus_bus_get_global_engine: assertion
> > (bus)' failed No engine is set.
> >
> > I originally had problems with the ibus-pinyin and the Chinese in
> ibus-m17n. But I have
> > not even got to try it yet, as ibus won't start. Thank you.
> I used to use ibus with ibus-anthy.  Now I am using it with ibus-kkc
> (not yet in unstable).
> So we use different engin.
> ibus-pinyin has bug
>   #746969 [src:ibus-pinyin] ibus-pinyin depends on Gobject Introspection
>  ==> Can you install gobject-introspection package?
> I have both ibus-m17n and ibus-pinyin installed.  So they should not
> break system foy you.
> If you are using ibus-setup to set, it may not be working... I did not
> use it.
> Osamu
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.alioth.debian.org/pipermail/pkg-ime-devel/attachments/20140508/12f7df16/attachment.html>

More information about the Pkg-ime-devel mailing list