[Pkg-ime-devel] Bug#747375: ibus-daemon does not start - no engine set and has no icon and cannot be run from command line

Osamu Aoki osamu_aoki_home at nifty.com
Thu May 8 14:49:17 UTC 2014


Please do not do TOP-POST.
I do not know if you followed all my points.
(Reordered to make this in logical order.)

> On Thu, May 8, 2014 at 8:29 AM, Osamu Aoki <osamu_aoki_home at nifty.com>wrote:
> > > ibus does not work and has not worked for a long time. I am a sid user.

When did it work?

> > Same here and ibus working OK here with GNOME3 started by GDM3.  What DE
> > do you use.

On Thu, May 08, 2014 at 10:15:53AM -0400, Dean Chia 贾定 wrote:
> I use Gnome3 - the standard that comes with Debian Sid.


> > > I have
> > > uninstalled a long while ago and have reinstalled recently. It does not
> > start; there is
> > > no menu, and I cannot even run it from the command line. If I run it in
> > terminal and
> > > type "ibus engine" I receive the following:
> >
> > I added few IMs via GNOME&s menu and tested.
> >
> > $ ibus engine
> > kkc
> > $ ibus engine
> > m17n:ja:tcode
> > $ ibus engine
> > pinyin
> > $ ibus engine
> > libpinyin

This means ibus-pinin works on my end.  You seem to be doing sopmething
wrong to me.  Are you sure you have bug.  (At least this is

> > > (process:17576): IBUS-CRITICAL **: ibus_bus_get_global_engine: assertion
> > > (bus)' failed No engine is set.
> > >
> > > I originally had problems with the ibus-pinyin and the Chinese in
> > ibus-m17n. But I have
> > > not even got to try it yet, as ibus won't start. Thank you.

You had problem.

> The ibus icon is now showing up in my gnome-task-panel on top. My engine is
> now registered as m17n:zh:py. Unfortunately, it still cannot type Chinese.
> And when I restarted my computer and did ibus-setup to start ibus-daemon
> (still no icon in Gnome Shell), it turned on ibus but than that replaced my
> normal keyboard input switches (I use US-Dvorak International, TIRO Hebrew,
> and Greek), so I had to re-activate them by removing and re-adding a
> keyboard back in System Settings --> Keyboard.

Sounds like you have a bit different situation.

> > I used to use ibus with ibus-anthy.  Now I am using it with ibus-kkc
> > (not yet in unstable).
> >
> > So we use different enginie.

Actually, I tested ibus-pinyin too.  It is OK.

> > ibus-pinyin has bug
> >   #746969 [src:ibus-pinyin] ibus-pinyin depends on Gobject Introspection
> >  ==> Can you install gobject-introspection package?

Did you do this?

> > I have both ibus-m17n and ibus-pinyin installed.  So they should not
> > break system foy you.
> >
> > If you are using ibus-setup to set, it may not be working... I did not
> > use it.

> I tried uninstalling and reinstalling ibus-pinyin as well as
> ibus-googlepinyin.

Wait.  You use ibus-googlepinyin, too.

Anyway, do they still causing errors such as:
  IBUS-CRITICAL **: ibus_bus_get_global_engine: assertion

Please test this with and without ibus-googlepinyin.

> However, it seems that there is no engine that drives my
> Chinese. All I get is more English.

How do you know?  Habve you installed required fonts?

By the way, is this your first time setting up this kind of things or
are you familiar with things?

If you do not know how, please seek help elsewhere.  This is bug report
communication only.

Also, have you configured system properly with "apt-get dist-upgrade"?
If you kept using "apt-get upgrade" only, system may get into funckey
situation beyond what we support.


More information about the Pkg-ime-devel mailing list