[pkg-kolab] Just installed kolab on lenny/arm, system settings blank

Mark J. Small msmall at eastlink.ca
Wed Dec 2 17:49:42 UTC 2009

On November 24, 2009, Mathieu Parent wrote:
> Hello,
> On Mon, Nov 23, 2009 at 6:49 PM, Mark J. Small <msmall at eastlink.ca> wrote:
> > Hi there,
> >
> > I'm in the process of setting up a new ARM box running Debian stable.  I
> > plan to run kolabd on this box but I'm running in to trouble.  I've
> > installed kolab according to the instructions here:
> >
> > http://wiki.kolab.org/index.php/Debian_-_Administrators_-
> > _Kolab_Installation#Web_administration_frontend
> >
> > using apt-pinning as suggested.  The install went fine, and I ran the
> > bootstrap without trouble.  I installed the webadmin package and ran the
> > sed scripts as instructed.
> This is the right way.
> > The trouble comes when I try to use the web admin interface.  It tells me
> > to first create a user account, and then set up forwarding of mail to
> > admin email addresses.  I create a user just fine, but when I try to set
> > up the forwarding, I'm sent to a blank page.  (Well, the lower pane is
> > blank.  The upper part has the standard Kolab links like Users,
> > Addressbook, Shared Folder, etc)
> You appear to have a fatal php error. Can you paste here the bottom of
> you /var/log/apache2/error.log ?
> Are the other tabs blank also ?
> > Also if I directly click on the Settings tab, again, everything is blank.
> >
> > Does anyone know where I can go from here?
> Mathieu Parent

I've been doing some testing trying to figure this one out.  I create two 
virtual machines in virtualbox (so now were looking at i386, not arm).  The 
first ran squeeze and kolab-webadmin worked fine.  The second ran lenny and 
kolab-webadmin showed the same problems as my arm box.  So the good news is 
that this is not a bug for squeeze.  

I started doing some apt-pinning to upgrade related packages to the squeeze 
versions to see if that would help.  Here is what I upgraded:

smarty, ldap-utils, libldap-2.4-2 slapd and whatever versioned dependencies 
those needed (perl, libgnutls26....)

all php5 related packaged, which also needed libc6, mysql stuff, horde.

all apache2 packages and libaprutil1

The actual kolab packages

sasl packages

all other php packages

After each group, I tried reconnecting and saw the same problems.  I also 
redid the kolab-bootstrap -b after most groups and that didn't help.

I'm tempted to start adding stuff the the settings.php file to see if I can 
track down the problem that way.  Does anyone have any hints?


More information about the pkg-kolab-devel mailing list