[Pkg-octave-devel] Bug#541444: Bug#541444: octave3.2-headers: can't be installed, two strong dependency on gcc/g++/gfortran

Thomas Weber thomas.weber.mail at gmail.com
Tue Aug 18 19:13:33 UTC 2009

Hi Aurelien,

On Fri, Aug 14, 2009 at 11:03:27AM +0200, Aurelien Jarno wrote:
> Package: octave3.2-headers
> Version: 3.2.0-2
> Severity: grave
> Justification: renders package unusable
> # apt-get install octave3.2-headers
> Reading package lists... Done
> Building dependency tree
> Reading state information... Done
> Some packages could not be installed. This may mean that you have
> requested an impossible situation or if you are using the unstable
> distribution that some required packages have not yet been created
> or been moved out of Incoming.
> The following information may help to resolve the situation:
> The following packages have unmet dependencies:
>   octave3.2-headers: Depends: gcc-4.3 (< 4.3.4) but 4.3.4-1 is to be installed
>                      Depends: g++-4.3 (< 4.3.4) but 4.3.4-1 is to be installed
>                      Depends: gfortran-4.3 (< 4.3.4) but 4.3.4-1 is to be installed

hmm, maybe I can abuse your knowledge with compilers for this one :)

The reason for tying the compiler versions so strict is that Octave adds
the FLIBS (Fortran) found at configure time into one of its scripts for
later use (building plugins, either in Debian or on the enduser's

FLIBS looks like this:
  -L/usr/lib/gcc/x86_64-linux-gnu/4.3.2/../../../../lib -L/lib/../lib
  -L/usr/lib/../lib -L/usr/lib/gcc/x86_64-linux-gnu/4.3.2/../../.. -lhdf5
  -lz -lgfortranbegin -lgfortran -lm

Do you know if it's possible to get rid of the version specific compiler
paths here? The macro is the default AC_F77_LIBRARY_LDFLAGS.


More information about the Pkg-octave-devel mailing list