[php-maint] PHPUnit testers wanted (2nd query)

arno arno at renevier.net
Wed Mar 23 16:58:35 UTC 2011


I'm interested in having a nice phpunit package in debian. So, I've tested the 
current work in progress by cloning, building and installing the following 
packagess: php-text-template php-file-iterator, php-timer, php-token-stream, 
php-code-coverage, php-symfony-yaml and phpunit. I have a few questions and 
remarks about them.

- Some packages have repositories in pkg-php/PACKAGE.git and 
I've chosen the ones in pkg-php/ because they looked more recent.  
php-code-coverage was only present in users/baloo-guest/, I could build and 
install it, but then, phpunit was not working:
$ phpunit
 PHP Fatal error:  Call to undefined method PHP_CodeCoverage_Filter::getInstance() in /usr/bin/phpunit on line 39
So, I have packaged new upstream version of php-code-coverage without touching 
debian/ directory and then it worked fine.

- php-text-template, php-timer, and php-token-stream build correctly with 
git-buildpackage, but a second build in a row will fail. Clean rules does not 
put everything back in its initial state. This happens because of 
two unrelated things: First, package.xml file is modified during build. When 
$(pear_pkg).tgz is uncompressed, the newly generated package.xml erases the 
old one. I think that this file is not needed in the debian package, so why 
not use tar -k option to avoid package.xml overriding. Then, the call to 
$ /usr/bin/pear -D php_dir=usr/share/php/ install -f -n -O -P debian/php-text-template/ package.xml
creates directory named debian/php-text-templateusr/ instead of putting things 
in debian/php-text-template/usr/ (missing '/'). Is this a bug in pear ?  I'm 
using pear 1.9.2 with php 5.3.6-2

- php-file-iterator contains a file 
/usr/share/doc/php-file-iterator/buildinfo.gz Is it really useful, or should 
it be removed ?

- in php-token-stream, phptok binary does not run correctly:
$ phptok
PHP Warning:  require_once(ezc/Base/base.php): failed to open stream: No such file or directory in /usr/share/php/PHP/Token/Stream/TextUI/Command.php on line 45
Also, the /usr/share/php/PHP/Token/Stream/TextUI/Command.php depends on some 
'ezc/Base/base.php' file wich is not packaged in debian.

- php-code-coverage has the same problem with /usr/bin/phpcov, 
/usr/share/php/PHP/CodeCoverage/Autoload.php.in and

after building and installing all those packages, I could build and install 
phpunit 3.5.5-2: it worked fine :)
I noticed just a minor thing: phpunit is stored in a git repo, but control 
file does not have a Vcs-Git field.

Let me known if I can do anything else to help having a good phpunit package.

arno renevier

More information about the pkg-php-maint mailing list