[Pkg-postgresql-public] dms-core: Uninstallable in sid, needs transitioning to PostgreSQL 9.4

Martin Pitt mpitt at debian.org
Tue Jul 29 04:46:39 UTC 2014

Package: dms-core
Version: 1.0.1g-5
Severity: serious


dms-core currently requires a specific major PostgreSQL version 9.3,
but it has versioned depends on the metapackages:

 postgresql (>= 9.3), postgresql (<< 9.4),
 postgresql-client (>= 9.3), postgresql-client (<< 9.4),

Please don't do that. If your package really needs a specific
PostgreSQL version, then depend on "postgresql-9.3" (-client is always
a dependency of that).

As a result dms is now uninstallable, as "postgresql" is version 9.4

Can you please check if it also works with the current 9.4, and fix
the dependencies accordingly?

Thank you in advance!


Martin Pitt                        | http://www.piware.de
Ubuntu Developer (www.ubuntu.com)  | Debian Developer  (www.debian.org)
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 819 bytes
Desc: Digital signature
URL: <http://lists.alioth.debian.org/pipermail/pkg-postgresql-public/attachments/20140729/f0919c02/attachment.sig>

More information about the Pkg-postgresql-public mailing list