[Pkg-postgresql-public] [Dms-maintainers] Bug#756352: dms-core: Uninstallable in sid, needs transitioning to PostgreSQL 9.4
matt at mattgrant.net.nz
Thu Jul 31 10:17:32 UTC 2014
Will get onto it this weekend, hopefully Saturday.
Need to dump and update DB schema for PostgresQL 9.4
Will also fix version dependency in debian/control as specified below,
but for postgresql-9.4.
Please give me a few days. Quite busy with work.
On Tue, 2014-07-29 at 06:46 +0200, Martin Pitt wrote:
> Package: dms-core
> Version: 1.0.1g-5
> Severity: serious
> dms-core currently requires a specific major PostgreSQL version 9.3,
> but it has versioned depends on the metapackages:
> postgresql (>= 9.3), postgresql (<< 9.4),
> postgresql-client (>= 9.3), postgresql-client (<< 9.4),
> Please don't do that. If your package really needs a specific
> PostgreSQL version, then depend on "postgresql-9.3" (-client is always
> a dependency of that).
> As a result dms is now uninstallable, as "postgresql" is version 9.4
> Can you please check if it also works with the current 9.4, and fix
> the dependencies accordingly?
> Thank you in advance!
> Dms-maintainers mailing list
> Dms-maintainers at lists.alioth.debian.org
Matt Grant, Debian and Linux Systems Administration and Consulting
Mobile: 021 0267 0578
Email: matt at mattgrant.net.nz
More information about the Pkg-postgresql-public