Bug#331029: marked as done (vim-gtk: gvim can't open files through right click menu in GNOME)

Debian Bug Tracking System owner at bugs.debian.org
Sun Dec 18 17:33:16 UTC 2005

Your message dated Sun, 18 Dec 2005 18:27:02 +0100
with message-id <20051218172702.GA14060 at aquarium.takhisis.invalid>
and subject line solved in vim 6.4-001+1
has caused the attached Bug report to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what I am
talking about this indicates a serious mail system misconfiguration
somewhere.  Please contact me immediately.)

Debian bug tracking system administrator
(administrator, Debian Bugs database)

Received: (at submit) by bugs.debian.org; 1 Oct 2005 03:12:59 +0000
>From carlosliu at users.sourceforge.net Fri Sep 30 20:12:59 2005
Return-path: <carlosliu at users.sourceforge.net>
Received: from smtp-out.free.net.nz [] 
	by spohr.debian.org with esmtp (Exim 3.36 1 (Debian))
	id 1ELXo2-0005x0-00; Fri, 30 Sep 2005 20:12:59 -0700
Received: from cliux.homeunix.net (unknown [])
	by smtp-out.free.net.nz (Postfix) with ESMTP id 20C3081A7;
	Sat,  1 Oct 2005 15:12:53 +1200 (NZST)
Received: from [] (localhost [])
	by cliux.homeunix.net (Postfix) with ESMTP id 6B2EE14FD48E;
	Sat,  1 Oct 2005 15:12:51 +1200 (NZST)
Content-Type: text/plain; charset="us-ascii"
MIME-Version: 1.0
Content-Transfer-Encoding: 7bit
From: "Carlos Z.F. Liu" <carlosliu at users.sourceforge.net>
To: Debian Bug Tracking System <submit at bugs.debian.org>
Subject: vim-gtk: gvim can't open files through right click menu in GNOME
Reply-To: "Carlos Z.F. Liu" <carlosliu at users.sourceforge.net>
X-Mailer: reportbug 3.17
Date: Sat, 01 Oct 2005 15:12:50 +1200
Message-Id: <20051001031251.6B2EE14FD48E at cliux.homeunix.net>
Delivered-To: submit at bugs.debian.org
X-Spam-Checker-Version: SpamAssassin 2.60-bugs.debian.org_2005_01_02 
	(1.212-2003-09-23-exp) on spohr.debian.org
X-Spam-Status: No, hits=-8.0 required=4.0 tests=BAYES_00,HAS_PACKAGE 
	autolearn=no version=2.60-bugs.debian.org_2005_01_02

Package: vim-gtk
Version: 1:6.3-086+1
Severity: normal


The reason is that gvim doesn't support "file://path/filename".
In /usr/share/applications/gvim.desktop, we should change
Exec=gvim %U
Exec=gvim %f


-- System Information:
Debian Release: testing/unstable
  APT prefers unstable
  APT policy: (500, 'unstable'), (1, 'experimental')
Architecture: i386 (i686)
Shell:  /bin/sh linked to /bin/bash
Kernel: Linux 2.6.12-1-686
Locale: LANG=en_NZ.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)

Versions of packages vim-gtk depends on:
ii  libatk1.0-0               1.10.3-1       The ATK accessibility toolkit
ii  libc6                     2.3.5-6        GNU C Library: Shared libraries an
ii  libglib2.0-0              2.8.1-1        The GLib library of C routines
ii  libgpmg1                  1.19.6-21      General Purpose Mouse - shared lib
ii  libgtk2.0-0               2.6.10-1       The GTK+ graphical user interface 
ii  libice6                   6.8.2.dfsg.1-7 Inter-Client Exchange library
ii  libncurses5               5.4-9          Shared libraries for terminal hand
ii  libpango1.0-0             1.8.2-2        Layout and rendering of internatio
ii  libsm6                    6.8.2.dfsg.1-7 X Window System Session Management
ii  libx11-6                  6.8.2.dfsg.1-7 X Window System protocol client li
ii  libxt6                    6.8.2.dfsg.1-7 X Toolkit Intrinsics
ii  vim                       1:6.3-086+1    Vi IMproved - enhanced vi editor
ii  xlibs                     6.8.2.dfsg.1-7 X Window System client libraries m

vim-gtk recommends no packages.

-- no debconf information

Received: (at 331029-done) by bugs.debian.org; 18 Dec 2005 17:28:04 +0000
>From zack at bononia.it Sun Dec 18 09:28:04 2005
Return-path: <zack at bononia.it>
Received: from sockmel.bononia.it ([])
	by spohr.debian.org with esmtp (Exim 4.50)
	id 1Eo2KK-0003cP-9h; Sun, 18 Dec 2005 09:28:04 -0800
Received: from muletto.takhisis.invalid (85-18-14-42.fastres.net [])
	(using TLSv1 with cipher DHE-RSA-AES256-SHA (256/256 bits))
	(Client CN "Stefano Zacchiroli", Issuer "sockmel.bononia.it" (verified OK))
	by sockmel.bononia.it (Postfix) with ESMTP id 5ED2C56E8D;
	Sun, 18 Dec 2005 18:28:02 +0100 (CET)
Received: by muletto.takhisis.invalid (Postfix, from userid 1000)
	id 51C8E440BC; Sun, 18 Dec 2005 18:27:02 +0100 (CET)
Date: Sun, 18 Dec 2005 18:27:02 +0100
From: Stefano Zacchiroli <zack at debian.org>
To: 331029-submitter at bugs.debian.org
Cc: 331029-done at bugs.debian.org
Subject: solved in vim 6.4-001+1
Message-ID: <20051218172702.GA14060 at aquarium.takhisis.invalid>
MIME-Version: 1.0
Content-Type: multipart/signed; micalg=pgp-sha1;
	protocol="application/pgp-signature"; boundary="2oS5YaxWCcQjTEyO"
Content-Disposition: inline
User-Agent: Mutt/1.5.11
X-Spam-Checker-Version: SpamAssassin 2.60-bugs.debian.org_2005_01_02 
	(1.212-2003-09-23-exp) on spohr.debian.org
X-Spam-Status: No, hits=-3.0 required=4.0 tests=BAYES_00 autolearn=no 

Content-Type: text/plain; charset=us-ascii
Content-Disposition: inline
Content-Transfer-Encoding: quoted-printable

This bug was fixed with the upload of vim 6.4-001+1 providing a patch
for netrw.

Thus '%U' in /usr/share/applications/gvim.desktop is now ok.

Thanks for the report.

Stefano Zacchiroli -*- Computer Science PhD student @ Uny Bologna, Italy
zack@{cs.unibo.it,debian.org,bononia.it} -%- http://www.bononia.it/zack/
If there's any real truth it's that the entire multidimensional infinity
of the Universe is almost certainly being run by a bunch of maniacs. -!-

Content-Type: application/pgp-signature; name="signature.asc"
Content-Description: Digital signature
Content-Disposition: inline

Version: GnuPG v1.4.2 (GNU/Linux)



More information about the pkg-vim-maintainers mailing list