[SCM] WebKit Debian packaging branch, debian/experimental, updated. upstream/1.3.3-9427-gc2be6fc

commit-queue at webkit.org commit-queue at webkit.org
Wed Dec 22 11:10:39 UTC 2010


The following commit has been merged in the debian/experimental branch:
commit 99f2a1d7570ae3ec919ec6d8ef500f4b85af9a3b
Author: commit-queue at webkit.org <commit-queue at webkit.org@268f45cc-cd09-0410-ab3c-d52691b4dbfc>
Date:   Wed Jul 14 14:22:49 2010 +0000

    2010-07-14  Hans Wennborg  <hans at chromium.org>
    
            Reviewed by Steve Block.
    
            Rename DeviceOrientationController::onOrientationChange to didChangeDeviceOrientation
            https://bugs.webkit.org/show_bug.cgi?id=42257
    
            According to convention, we should avoid "on" in favor of "did" in function names.
    
            * dom/DeviceOrientationController.cpp:
            (WebCore::DeviceOrientationController::didChangeDeviceOrientation):
            * dom/DeviceOrientationController.h:
    
    git-svn-id: http://svn.webkit.org/repository/webkit/trunk@63317 268f45cc-cd09-0410-ab3c-d52691b4dbfc

diff --git a/WebCore/ChangeLog b/WebCore/ChangeLog
index f3c10dc..9a63225 100644
--- a/WebCore/ChangeLog
+++ b/WebCore/ChangeLog
@@ -1,3 +1,16 @@
+2010-07-14  Hans Wennborg  <hans at chromium.org>
+
+        Reviewed by Steve Block.
+
+        Rename DeviceOrientationController::onOrientationChange to didChangeDeviceOrientation
+        https://bugs.webkit.org/show_bug.cgi?id=42257
+
+        According to convention, we should avoid "on" in favor of "did" in function names.
+
+        * dom/DeviceOrientationController.cpp:
+        (WebCore::DeviceOrientationController::didChangeDeviceOrientation):
+        * dom/DeviceOrientationController.h:
+
 2010-07-14  Lucas De Marchi  <lucas.demarchi at profusion.mobi>
 
         Reviewed by Kent Tamura.
diff --git a/WebCore/dom/DeviceOrientationController.cpp b/WebCore/dom/DeviceOrientationController.cpp
index 204c796..f6867ec 100644
--- a/WebCore/dom/DeviceOrientationController.cpp
+++ b/WebCore/dom/DeviceOrientationController.cpp
@@ -76,7 +76,7 @@ void DeviceOrientationController::removeAllListeners(DOMWindow* window)
         m_client->stopUpdating();
 }
 
-void DeviceOrientationController::onDeviceOrientationChange(DeviceOrientation* orientation)
+void DeviceOrientationController::didChangeDeviceOrientation(DeviceOrientation* orientation)
 {
     RefPtr<DeviceOrientationEvent> event = DeviceOrientationEvent::create(eventNames().deviceorientationEvent, orientation);
     Vector<DOMWindow*> listenersVector;
diff --git a/WebCore/dom/DeviceOrientationController.h b/WebCore/dom/DeviceOrientationController.h
index f8ad8b4..376e14c 100644
--- a/WebCore/dom/DeviceOrientationController.h
+++ b/WebCore/dom/DeviceOrientationController.h
@@ -43,7 +43,7 @@ public:
     void removeListener(DOMWindow*);
     void removeAllListeners(DOMWindow*);
 
-    void onDeviceOrientationChange(DeviceOrientation*);
+    void didChangeDeviceOrientation(DeviceOrientation*);
 
 private:
     Page* m_page;

-- 
WebKit Debian packaging



More information about the Pkg-webkit-commits mailing list