[Pkg-xfce-devel] Bug#448352: Bug#448352: thunar: Cannot mount USB devices anymore

Mathias Brodala info at noctus.net
Fri Nov 2 16:59:42 UTC 2007


Yves-Alexis Perez, 02.11.2007 17:35:
> On Sun, Oct 28, 2007 at 11:37:19AM +0000, Mathias Brodala wrote:
>> Package: thunar
>> Version: 0.8.0-5.1~gnomethumbnailers
>> Severity: important
>> For some days now I cannot mount USB devices anymore. Thunar tells me:
>>> Failed to mount "$device"
>>> You are not privileged to mount the volume "$device"
>> ($device obviously being the device’s label.)
>> It worked without problems before.
> I'm adding Mathias Brodal, hal maintainer, in the CC: field because I guess
> it's a hal issue, but I'm not sure. It may be a problem with the new fdi
> provided by hal 0.5.10, or something like that. 

But it didn’t work either after temporarily downgrading hal to Testing version

> But I tried to use pmount-hal (wich would check hal policies before mount) and
> it works fine. So I'm a bit lost.

Works fine here too, also pumount’ing it, but once again unmounting via Thunar
fails with a similar error message.

> Mathias, do you have informations about a possible regression on hal
> concerning usb mounting?

Sorry, can’t tell you much here. I never directly invoke hal for mounting
devices, I only used Thunar since the day I discovered that it can mount devices
"just like that".

> If you need information about devices (lshal, logs
> etc.) please ask.

Well, all I can do is to provide this information, not much I can do about it

Regards, Mathias


-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 252 bytes
Desc: OpenPGP digital signature
Url : http://lists.alioth.debian.org/pipermail/pkg-xfce-devel/attachments/20071102/b4c3f651/attachment.pgp 

More information about the Pkg-xfce-devel mailing list