[Pkg-xfce-devel] Bug#523517: xfce4-settings: <Alt> and <Meta> keyboard settings swapped

Dave Witbrodt dawitbro at sbcglobal.net
Fri Apr 10 19:33:44 UTC 2009

Package: xfce4-settings
Version: 4.6.0-2
Severity: normal

Today I discovered that my XFCE keyboard configuration has become
confused, with the <Alt> key being swapped with the <Meta> key in many
cases.  I have been using keyboard Application Shortcuts bound to
<Ctrl><Alt>-t and <Ctrl><Alt>-b for a long time, and just discovered
they were no longer working.

I recently upgraded from XFCE 4.4 to XFCE 4.6 in Sid, and today upgraded
xorg from 7.3 to 7.4.  I cannot say with confidence which upgrade
introduced the problem -- I had other, more visible problems with the
XFCE upgrade, which I was able to solve by manually changing the icon
theme -- so I was not checking keyboard behavior.  The xorg upgrade
_did_ have the effect of disabling the old X keyboard driver and
switching me to evdev, so that may well be the cause.

In the file ~/.config/xfce4/xfconf/xfce-perchannel-xml/xfce4-keyboard-shortcuts.xml
I currently have settings like this:

    <channel name="xfce4-keyboard-shortcuts" version="1.0">
      <property name="commands" type="empty">
	<property name="default" type="empty">
	<property name="custom" type="empty">
*	  <property name="&lt;Alt&gt;F2" type="string" value="xfrun4"/>
!	  <property name="&lt;Control&gt;&lt;Alt&gt;Delete" type="string" value="xflock4"/>
	  <property name="XF86Display" type="string" value="xrandr --auto"/>
	  <property name="override" type="bool" value="true"/>
	  <property name="XF86AudioMute" type="string" value="aumix -v0"/>
	  <property name="XF86AudioLowerVolume" type="string" value="aumix -v-10"/>
	  <property name="XF86AudioRaiseVolume" type="string" value="aumix -v+10"/>
	  <property name="&lt;Control&gt;Escape" type="string" value="xfce4-popup-menu"/>
	  <property name="&lt;Meta&gt;F1" type="string" value="xfhelp4"/>
!	  <property name="&lt;Control&gt;&lt;Meta&gt;Delete" type="string" value="xflock4"/>
*	  <property name="&lt;Meta&gt;F2" type="string" value="xfrun4"/>
	  <property name="&lt;Control&gt;&lt;Meta&gt;Escape" type="string" value="xkill"/>
	  <property name="&lt;Control&gt;&lt;Alt&gt;t" type="string" value="exo-open --launch TerminalEmulator"/>
	  <property name="&lt;Control&gt;&lt;Alt&gt;b" type="string" value="exo-open --launch WebBrowser"/>

The last 2 entries shown here are my Application Shortcuts.  Under XFCE
v4.4 I had defined these using <Ctrl><Alt>, and they somehow had changed
to <Ctrl><Meta> today.  What you see above is the result of deleting the
shortcuts and manually resetting them to use <Ctrl><Alt> instead.

Also notice the lines marked (*) and (!), which are pairs of lines with
different shortcuts for the same command.  This is not my doing... and
when I noticed this I realized that something bad had happened to my
keyboard configuration, so I thought I should report it.

[I ran 'reportbug' with "--attach=~/.config/.../xfce4-keyboard-shortcuts.xml", 
so the entire file should be attached in case it would be helpful.  I
found that no 'keyboard-layout.xml' file existed in that directory, but
was able to produce it by running the Settings app and going to 

    Keyboard --> Layout

and clicking Edit, then "OK".  Restarting X did not produce any change
in behavior.]

I did not know whether I should add this report to the similar, but
recently-closed report I see on the BTS, or whether I should start a new
one.  After reading the other thread, I made a guess that this is
different enough that it should be its own report.

I am still trying to solve other keyboard-related issues:

1)  In DOSBox the numeric keypad <Enter> is not recognized the
    same as the main <Enter> key, but it works fine in apps such as
    'mousepad', 'xfce4-terminal', and 'xfce4-notes-plugin'.  This 
    key used to work fine in DOSBox.  Numlock status has no effect.

2)  Using <Ctrl><Alt><Shift>-arrow to move a window fails, as does
    <Alt><Shift>-arrow to resize a window,  but these worked fine
    last time I tried it (with XFCE 4.4).

3)  In 'xfce4-terminal', the key combinations <Alt>-left and
    <Ctrl>-left cause 'D' to be printed, and <Alt>-right and
    <Ctrl>-right cause 'C' to be printed.  (Other combinations also
    produce strange, wrong results... so these are merely specific
    examples.)  This behavior was not seen before.

I would like to be able to resize windows with <Alt><Shift>-arrow, and
move windows with <Ctrl><Alt><Shift>-arrow, again because I became so
conditioned to these key combinations.  I have started retraining myself
to use <Alt>-F8 and <Alt>-F7 in the meantime, though.

I'll be glad to provide more info to help track down the causes of these
annoyances, so just let me know how I can help.

-- System Information:
Debian Release: squeeze/sid
  APT prefers unstable
  APT policy: (990, 'unstable'), (350, 'experimental')
Architecture: amd64 (x86_64)

Kernel: Linux 2.6.28-2s13145.090321.desktop.uvesafb (SMP w/2 CPU cores; PREEMPT)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/bash

Versions of packages xfce4-settings depends on:
ii  libc6                         2.9-7      GNU C Library: Shared libraries
ii  libcairo2                     1.8.6-2+b1 The Cairo 2D vector graphics libra
ii  libdbus-glib-1-2              0.80-3     simple interprocess messaging syst
ii  libexo-0.3-0                  0.3.100-2  Library with extensions for Xfce
ii  libglade2-0                   1:2.6.4-1  library to load .glade files at ru
ii  libglib2.0-0                  2.20.0-3   The GLib library of C routines
ii  libgtk2.0-0                   2.14.7-5   The GTK+ graphical user interface 
ii  libnotify1 [libnotify1-gtk2.1 0.4.5-1    sends desktop notifications to a n
ii  libpango1.0-0                 1.24.0-3   Layout and rendering of internatio
ii  libwnck22                     2.24.2-2   Window Navigator Construction Kit 
ii  libx11-6                      2:1.2.1-1  X11 client-side library
ii  libxcursor1                   1:1.1.9-1  X cursor management library
ii  libxfce4util4                 4.6.0-2    Utility functions library for Xfce
ii  libxfcegui4-4                 4.6.0-2    Basic GUI C functions for Xfce4
ii  libxfconf-0-2                 4.6.0-3    Client library for Xfce4 configure
ii  libxi6                        2:1.2.1-2  X11 Input extension library
ii  libxklavier12                 3.7-2      X Keyboard Extension high-level AP
ii  libxrandr2                    2:1.3.0-2  X11 RandR extension library
ii  xfconf                        4.6.0-3    utilities for managing settings in

Versions of packages xfce4-settings recommends:
ii  aumix-gtk [aumix]             2.8-22     Simple mixer control program with 
ii  x11-utils                     7.4+1      X11 utilities

xfce4-settings suggests no packages.

-- no debconf information
-------------- next part --------------
A non-text attachment was scrubbed...
Name: xfce4-keyboard-shortcuts.xml
Type: application/xml
Size: 9548 bytes
Desc: not available
URL: <http://lists.alioth.debian.org/pipermail/pkg-xfce-devel/attachments/20090410/59126c60/attachment-0001.xml>

More information about the Pkg-xfce-devel mailing list