[Pkg-xfce-devel] Bug#523517: Bug#523517: xfce4-settings: <Alt> and <Meta> keyboard settings swapped

Yves-Alexis Perez corsac at debian.org
Fri Apr 10 21:41:38 UTC 2009

On ven, 2009-04-10 at 15:33 -0400, Dave Witbrodt wrote:
> Today I discovered that my XFCE keyboard configuration has become
> confused, with the <Alt> key being swapped with the <Meta> key in many
> cases.  I have been using keyboard Application Shortcuts bound to
> <Ctrl><Alt>-t and <Ctrl><Alt>-b for a long time, and just discovered
> they were no longer working.
> I recently upgraded from XFCE 4.4 to XFCE 4.6 in Sid, and today upgraded
> xorg from 7.3 to 7.4.  I cannot say with confidence which upgrade
> introduced the problem -- I had other, more visible problems with the
> XFCE upgrade, which I was able to solve by manually changing the icon
> theme -- so I was not checking keyboard behavior.  The xorg upgrade
> _did_ have the effect of disabling the old X keyboard driver and
> switching me to evdev, so that may well be the cause.

Yes, the concurrent upgrades means that it's a bit difficult to track
down the problems. Especially since xorg use hal now, so some people now
have it installed while they didn't before.

Basically, to track down problems it might be worth trying with a fresh
config, so see if it's related to soft or config.
> In the file ~/.config/xfce4/xfconf/xfce-perchannel-xml/xfce4-keyboard-shortcuts.xml
> I currently have settings like this:
>     <channel name="xfce4-keyboard-shortcuts" version="1.0">
>       <property name="commands" type="empty">
> 	<property name="default" type="empty">
> [...]
> 	</property>
> 	<property name="custom" type="empty">
> *	  <property name="&lt;Alt&gt;F2" type="string" value="xfrun4"/>
> !	  <property name="&lt;Control&gt;&lt;Alt&gt;Delete" type="string" value="xflock4"/>
> 	  <property name="XF86Display" type="string" value="xrandr --auto"/>
> 	  <property name="override" type="bool" value="true"/>
> 	  <property name="XF86AudioMute" type="string" value="aumix -v0"/>
> 	  <property name="XF86AudioLowerVolume" type="string" value="aumix -v-10"/>
> 	  <property name="XF86AudioRaiseVolume" type="string" value="aumix -v+10"/>
> 	  <property name="&lt;Control&gt;Escape" type="string" value="xfce4-popup-menu"/>
> 	  <property name="&lt;Meta&gt;F1" type="string" value="xfhelp4"/>
> !	  <property name="&lt;Control&gt;&lt;Meta&gt;Delete" type="string" value="xflock4"/>
> *	  <property name="&lt;Meta&gt;F2" type="string" value="xfrun4"/>
> 	  <property name="&lt;Control&gt;&lt;Meta&gt;Escape" type="string" value="xkill"/>
> 	  <property name="&lt;Control&gt;&lt;Alt&gt;t" type="string" value="exo-open --launch TerminalEmulator"/>
> 	  <property name="&lt;Control&gt;&lt;Alt&gt;b" type="string" value="exo-open --launch WebBrowser"/>
> 	</property>
>       </property>
> [...]
> The last 2 entries shown here are my Application Shortcuts.  Under XFCE
> v4.4 I had defined these using <Ctrl><Alt>, and they somehow had changed
> to <Ctrl><Meta> today.  What you see above is the result of deleting the
> shortcuts and manually resetting them to use <Ctrl><Alt> instead.

It would have been nice to know if this was the result of the migration
script, or the result of the X changes. Basically I think that alt/meta
can just be the same (physical) key (the “Alt” one) but which can be
differently mapped to alt or meta. And it may depend on the selected
keyboard and/or layout.
> Also notice the lines marked (*) and (!), which are pairs of lines with
> different shortcuts for the same command.  This is not my doing... and
> when I noticed this I realized that something bad had happened to my
> keyboard configuration, so I thought I should report it.

Yes, some are your migrated settings from Xfce 4.4, and some are the
default settings in Xfce 4.6. You can clean the ones you don't need.

> I did not know whether I should add this report to the similar, but
> recently-closed report I see on the BTS, or whether I should start a new
> one.  After reading the other thread, I made a guess that this is
> different enough that it should be its own report.

Yeah, I'm not that sure but it's better to have a different issue, it's
becoming quite messy quite easily so I prefer having to merge if
needed :)
> I am still trying to solve other keyboard-related issues:
> 1)  In DOSBox the numeric keypad <Enter> is not recognized the
>     same as the main <Enter> key, but it works fine in apps such as
>     'mousepad', 'xfce4-terminal', and 'xfce4-notes-plugin'.  This 
>     key used to work fine in DOSBox.  Numlock status has no effect.

I don't know DOSBox. I'd say it's not an Xfce issue, but…
> 2)  Using <Ctrl><Alt><Shift>-arrow to move a window fails, as does
>     <Alt><Shift>-arrow to resize a window,  but these worked fine
>     last time I tried it (with XFCE 4.4).

Yes, this is expected, see below.
> 3)  In 'xfce4-terminal', the key combinations <Alt>-left and
>     <Ctrl>-left cause 'D' to be printed, and <Alt>-right and
>     <Ctrl>-right cause 'C' to be printed.  (Other combinations also
>     produce strange, wrong results... so these are merely specific
>     examples.)  This behavior was not seen before.

If it should run a shortcut, then just (re)bind it at the correct place
(I guess xfce4-terminal shortcuts settings). If it shouldn't, than
there's not much to do about it. (for the record, here alt+left
produces ;3D). And I'd say it's vte related :)
> I would like to be able to resize windows with <Alt><Shift>-arrow, and
> move windows with <Ctrl><Alt><Shift>-arrow, again because I became so
> conditioned to these key combinations.  I have started retraining myself
> to use <Alt>-F8 and <Alt>-F7 in the meantime, though.

Yeah, you'll really have to do that, because the resize is gone
completely. I'm not sure what Alt-F7 and Alt-F8 are bound to by default,
but you can bind a key to “resize“ (and then use the arrow keys). One
really nice feature of Xfce 4.6 is the “fill” resize. Really nice
(you'll find the three shortcuts on the WM Shortcut settings)

-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 197 bytes
Desc: This is a digitally signed message part
URL: <http://lists.alioth.debian.org/pipermail/pkg-xfce-devel/attachments/20090410/f49c3813/attachment.pgp>

More information about the Pkg-xfce-devel mailing list