[Pkg-xfce-devel] Bug#849072: lightdm: add-seat badly documented, apparently deprecated

ydirson at free.fr ydirson at free.fr
Thu Dec 22 12:52:15 UTC 2016

Package: lightdm
Version: 1.18.2-2

While "dm-tool add-nested-seat" does work, it is not suitable for all uses, and "dm-tool add-seat" looks like
the way to launch a real new X session.

* manpage mentions the syntax is "dm-tool add-seat TYPE" without giving any clue as to what TYPE should be
* https://answers.launchpad.net/lightdm/+question/176458 and https://bbs.archlinux.org/viewtopic.php?id=185297
  hint about "xlocal/xremote" as possible types
* all TYPEs I tried resulted in this error:

# dm-tool add-seat xlocal
Unable to add seat: GDBus.Error:org.freedesktop.DBus.Error.InvalidArgs: AddSeat is deprecated

Looks like the message comes from lightdm itself!

    if (g_strcmp0 (method_name, "AddSeat") == 0)
        g_dbus_method_invocation_return_error (invocation, G_DBUS_ERROR, G_DBUS_ERROR_INVALID_ARGS, "AddSeat is deprecated");
    else if (g_strcmp0 (method_name, "AddLocalXSeat") == 0)

At least the manpage should tell it's not supposed to work anymore, and explain how to replace
the feature.

* switch-to-greater works, unless one wants to open a new session as a user already logged in
* with add-local-x-seat we can get things to work with:

I tried:

# X :1 &
# dm-tool add-local-x-seat 1

... which does work, but with several inconveniences:

* we have to find out by hand which tty was selected - I get tty2 or tty3 (despite a getty running there), instead of expected tty8,
  ie. the tty constraints obeyed by lightdm do not apply
* dm-tool switch-to-user is of no use to discover this tty with several sessions for the same user

More information about the Pkg-xfce-devel mailing list